Transmission Update: Speed Sensor Diagnostics – UnderhoodService
Connect with us
Close Sidebar Panel Open Sidebar Panel

Engine

Transmission Update: Speed Sensor Diagnostics

Weird and unusual problems are my bread and butter diagnostics. By the time these odd problems get to me the owner of the vehicle has more than likely reached their threshold of poor diagnostics skills and bad results. Their opinion of every technician out there comes down to the same inevitable answer: “We’re all the same.” I doubt that very seriously. It’s almost laughable when you start quizzing them on where they had their car prior to bringing it in.

Advertisement

Advertisement
Weird and unusual problems are my bread and butter diagnostics. By the time these odd problems get to me the owner of the vehicle has more than likely reached their threshold of poor diagnostics skills and bad results. 

Their opinion of every technician out there comes down to the same inevitable answer: “We’re all the same.”  I doubt that very seriously.  It’s almost laughable when you start quizzing them on where they had their car prior to bringing it in.

 
The usual problem is money. Money dictates where these folks will go to get their car fixed.  That is until the problem isn’t a typical type of problem that the shop has either heard of before, or asked around long enough till they found an answer.  Those shops that try to get by doing basic repairs are fine.  I’d like to have some easy problems once in awhile too.  However, if you rely on someone else to find the answer for you, you’ll soon find yourself stuck with a problem that only good diagnostic skills and experience will solve.
 
I’ll bet in your town or city “ALL” the good shops know each other, and those shops know which shops are “NOT” so good.  So, when one of these weird jobs makes its way to my door, I’d like to know where it’s been. It’s why I ask that age old question, “Where did you have the car last?”  Sometimes, they’ll tell me, sometimes not.  
 
My latest weird problem was on a 1995 Suburban with a shifting problem. The customer’s way of explaining it was just as weird. His explanation of the problem was that a speed sensor (he called it a wheel sensor, but I knew what he meant) was causing his vehicle to not go any faster than 40 mph. Really? That’s a new one on me. Even in limp mode you can still get it above 40 mph. But I’ll go with what he’s telling me until I find out for myself.  
 
I checked for codes first. It only had one code — loss of VSS (vehicle speed sensor). Obviously, he’s been coached as to what to tell me, or has heard the terminology before, probably from the last shop.
 
I cleared the code and drove it around the block. It shifted perfectly and I didn’t have a problem getting it up to highway speeds.  After a few trips around the block, it suddenly jumped out of gear and dropped to 2nd gear.  
 

The sound and vibrations from the massive slam of the transmission sounded like somebody smacked it with a huge sledge hammer. Since I was driving with the scanner hooked up, I pulled over to read any changes. The code was back.  Time to head back to the shop and do a little research.
 
One of the things that made this problem even more of a problem was the fact that the speed sensor runs through a speed buffer and the PCM before it reaches the dash. And, the scanner reads through the PCM for its data so you’re not exactly reading the signal at the speed sensor. You aren’t reading the data from the speed buffer module either. You’re actually reading the results as they enter the PCM, and how the PCM interprets that info.    
 
This one was going to take some studying to get anywhere. One of the things that I noticed was that if I cleared the code, it would shift normally for several trips around the block before it slammed back into limp mode. 
Advertisement
Part of the diagnostic procedure said to read the transmission output signal while driving.  The signal was all over the place. One second it would be “0” and other times it was normal. 
 
Before hooking up a meter directly to the speed sensor, which was the next step, I thought I would put it up on a lift and take a look at the sensor. It looked like somebody had helped me out.  The sensor was old and dirty, but the connector was fresh and clean.  The connector was poorly attached to the factory wiring. (I think the last shop is showing their expertise).  Anytime I see electrical tape wrapped around a section of wire, I want to see what’s under it. 
 
I checked the sensor itself, while spinning the tires with it on the lift. Sure enough, the signal was dropping off very erratically. OK, it needs a sensor … super … an easy fix. But that didn’t explain why it took several trips around the block before it would go nuts. My guess was that something else was causing that part of the problem, because if this erratic signal was there, even at the speed I could hand spin the tires,  there was no doubt it was there at road speeds too.  
 
After installing the new speed sensor (not a cheap one, that’s for sure), I took it back around the block.  This time the speedometer was having a spastic attack. (It never did this before.) The speedometer was jumping erratically, slinging from 0 all the way to its max, and the transmission was stuck in limp mode from the very moment I got it up to speed. 
 
Let’s think about this. Before it would shift fine for a few trips, but now it won’t shift at all, and the dash has gone nuts. Sounds like a buffer. (Ya think?) Back to the shop again. I called to find a replacement part, and made another call to the customer and told him what I’ve found out so far.  I asked him if he knew when the connector to the speed sensor was changed. He told me it was what the last shop thought was wrong with it, but after changing the connector, it was worse. (You could have told me about this when you dropped it off … might have been helpful.)
Advertisement
“OK, before we order a buffer, let me check those leads and make sure they are making good connection,” I told him.
 
Looking at the prints showed one more thing to think about. There are two leads to this speed sensor, and the two leads do not go to the same place on the buffer.  And wouldn’t ya know it … the two wires on the speed sensor connector is not only poorly spliced together, they are also wired backwards.  
 
After putting the right wire on the right post, it was time for another drive test. Now how about that, it shifts fantastic! I took it around on the same route as before. This time I kept going and going, around and around.  It never slammed into gear, and it never went back into limp mode. It shifted up and down perfectly, and drove as if it was new.  
 
My customer was totally ecstatic.  After all he went through from the other shop; and all it turned out to be was a bad speed sensor that was compounded with the wires on the sensor being on backwards. 

He told me, “I’ve learned my lesson.  Next time I’m not going with the cheapest shop because cheap doesn’t always mean good service.” A lesson learned.  
 
There’s a quote I have hanging in my lobby that says it all: 
 
 “It’s unwise to pay too much, but it is worse to pay too little.  When you pay too much, you lose a little money — that’s all.  When you pay too little, you sometimes lose everything, because the thing you bought was incapable of doing the thing it was bought to do. The common law of business balance prohibits paying too little and getting a lot — it can,t be done. If you deal with the lowest bidder, it is well to add something for the risk you run, and if you do that you will have enough to pay for something better. "
–John Ruskin 1819-1900  

Advertisement
Click to comment
Connect
UnderhoodService