<!DOCTYPE html>
<html lang="en-US">
<head>

<meta name="be:sdk" content="php_sdk_1.5.3" />
<meta name="be:timer" content="36ms" />
<meta name="be:orig_url" content="https%3A%2F%2Fwww.underhoodservice.com%2Fusing-j2534-programming-devices%25EF%25BF%25BC%2F" />
<meta name="be:norm_url" content="https%3A%2F%2Fwww.underhoodservice.com%2Fusing-j2534-programming-devices%25EF%25BF%25BC%2F" />
<meta name="be:capsule_url" content="https%3A%2F%2Fixfd1-api.bc0a.com%2Fapi%2Fixf%2F1.0.0%2Fget_capsule%2Ff00000000270544%2F0152509416" />
<meta name="be:diag" content="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" />
<meta name="be:messages" content="true" />
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="shortcut icon" href="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-favicon-512x512-1.png" /><link rel="pingback" href="https://www.underhoodservice.com/xmlrpc.php" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-1000x563.jpg" />
<meta name="twitter:image" content="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-1000x563.jpg" />
<meta property="og:url" content="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/" />
<meta property="og:title" content="Using J2534 Programming Devices" />
<meta property="og:description" content="How much money are you losing by not programming?" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/">
<meta name="twitter:title" content="Using J2534 Programming Devices">
<meta name="twitter:description" content="How much money are you losing by not programming?">
<link href="https://fonts.googleapis.com/css?family=Anton&display=swap" rel="stylesheet">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-W7XCV9K');</script>


<script type="text/plain" data-consent-category="Tracking" async src="https://www.googletagmanager.com/gtag/js?id=G-0V66KSCRHP"></script>
<script type="text/plain" data-consent-category="Tracking">
			window.dataLayer = window.dataLayer || [];
			function gtag(){dataLayer.push(arguments);}
			gtag('js', new Date());

			gtag('config', 'G-0V66KSCRHP');
		</script>
<script type="text/plain" data-consent-category="Tracking">
            (function() {
                (function (i, s, o, g, r, a, m) {
                    i['GoogleAnalyticsObject'] = r;
                    i[r] = i[r] || function () {
                        (i[r].q = i[r].q || []).push(arguments)
                    }, i[r].l = 1 * new Date();
                    a = s.createElement(o),
                    console.log("o = " + o);
                    m = s.getElementsByTagName(o)[0];
                    a.async = 1;
                    a.src = g;
                    a.addEventListener("load", function(event) {
                        loadIpMetaScriptAndMakeIpMetaCalls();
                    });
                    m.parentNode.insertBefore(a, m)
                })(window, document, 'script', 'https://google-analytics.com/analytics.js', 'ga');

                ga('create', 'UA-1950768-13', 'auto');
                ga('send', 'pageview');
            })();
        </script>
<script type="text/javascript">
          function loadIpMetaScriptAndMakeIpMetaCalls() {

            // load ipmeta.io and add an onload handler that will call the ipMeta functions.
            var ipMetaScrip = document.createElement('script');
            var firstOtherScript = document.getElementsByTagName('script')[0];      
            firstOtherScript.parentNode.insertBefore(ipMetaScrip, firstOtherScript);
            ipMetaScrip.async = "";
            ipMetaScrip.src = "https://ipmeta.io/plugin.js";
            ipMetaScrip.addEventListener("load", function(event) {
              ga('require', 'ipMeta', {
                apiKey: '4143700411efe16f49122113a028fb7a2362874771861b4931d1d27754237b3b',
                serviceProvider: 'dimension1',
                networkDomain: 'dimension2',
                networkType: 'dimension3'
              });
              ga('ipMeta:loadNetworkFields');
            });
          }
        </script>

<script type="text/plain" data-consent-category="Advertising">
	    !function(f,b,e,v,n,t,s)
	    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
	    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
	    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
	    n.queue=[];t=b.createElement(e);t.async=!0;
	    t.src=v;s=b.getElementsByTagName(e)[0];
	    s.parentNode.insertBefore(t,s)}(window, document,'script',
	    'https://connect.facebook.net/en_US/fbevents.js');
	    fbq('init', '921089685038334');
	    fbq('track', 'PageView');
	    </script>
<noscript><img height="1" width="1" style="display:none"
	    src="https://www.facebook.com/tr?id=921089685038334&ev=PageView&noscript=1"/>
	    </noscript>

<link rel="stylesheet" href="https://olytics.omeda.com/olytics/css/v3/p/olytics.css" />
<script type="text/javascript">
	    // olytics 3.0
	    window.olytics||(window.olytics=[]),window.olytics.methods=["fire","confirm"],window.olytics.factory=function(i){return function(){var t=Array.prototype.slice.call(arguments);return t.unshift(i),window.olytics.push(t),window.olytics}};for(var i=0;i<window.olytics.methods.length;i++){var method=window.olytics.methods[i];window.olytics[method]=window.olytics.factory(method)}olytics.load=function(i){if(!document.getElementById("olyticsImport")){window.a=window.olytics;var t=document.createElement("script");t.async=!0,t.id="olyticsImport",t.type="text/javascript";var o="";void 0!==i&&void 0!==i.oid&&(o=i.oid),t.setAttribute("data-oid",o),t.src="https://olytics.omeda.com/olytics/js/v3/p/olytics.min.js",t.addEventListener("load",function(t){for(olytics.initialize({Olytics:i});window.a.length>0;){var o=window.a.shift(),s=o.shift();olytics[s]&&olytics[s].apply(olytics,o)}},!1);var s=document.getElementsByTagName("script")[0];s.parentNode.insertBefore(t,s)}},olytics.load({oid:"624a0969958c434da5dcf658ddec1ded"});
	    </script>

<title>Using J2534 Programming Devices</title>
<meta name="description" content="There are tons of repair procedures that cannot be completed without a flash or recode. How much money are you losing by not doing it?" />
<link rel="canonical" href="https://www.underhoodservice.com/using-j2534-programming-devices￼/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Using J2534 Programming Devices" />
<meta property="og:description" content="There are tons of repair procedures that cannot be completed without a flash or recode. How much money are you losing by not doing it?" />
<meta property="og:url" content="https://www.underhoodservice.com/using-j2534-programming-devices￼/" />
<meta property="og:site_name" content="UnderhoodService" />
<meta property="article:publisher" content="https://www.facebook.com/UnderhoodService" />
<meta property="article:published_time" content="2022-06-24T12:16:26+00:00" />
<meta property="article:modified_time" content="2022-06-24T12:22:25+00:00" />
<meta property="og:image" content="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg" />
<meta property="og:image:width" content="1400" />
<meta property="og:image:height" content="700" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@underhoodserv" />
<meta name="twitter:site" content="@underhoodserv" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Donny Seyfer" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="8 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.underhoodservice.com/#website","url":"https://www.underhoodservice.com/","name":"UnderhoodService","description":"Technical resources to help diagnose and repair engine-related service issues.","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.underhoodservice.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/#primaryimage","url":"https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg","contentUrl":"https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg","width":1400,"height":700},{"@type":"WebPage","@id":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/#webpage","url":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/","name":"Using J2534 Programming Devices","isPartOf":{"@id":"https://www.underhoodservice.com/#website"},"primaryImageOfPage":{"@id":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/#primaryimage"},"datePublished":"2022-06-24T12:16:26+00:00","dateModified":"2022-06-24T12:22:25+00:00","author":{"@id":"https://www.underhoodservice.com/#/schema/person/4e885a161ba64aa5cbdb1eace20317d7"},"description":"There are tons of repair procedures that cannot be completed without a flash or recode. How much money are you losing by not doing it?","breadcrumb":{"@id":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/"]}]},{"@type":"BreadcrumbList","@id":"https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.underhoodservice.com/"},{"@type":"ListItem","position":2,"name":"Using J2534 Programming Devices"}]},{"@type":"Person","@id":"https://www.underhoodservice.com/#/schema/person/4e885a161ba64aa5cbdb1eace20317d7","name":"Donny Seyfer","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.underhoodservice.com/#/schema/person/image/","url":"https://s19539.pcdn.co/wp-content/uploads/2016/01/Screen-Shot-2016-01-18-at-1.34.21-PM.png","contentUrl":"https://s19539.pcdn.co/wp-content/uploads/2016/01/Screen-Shot-2016-01-18-at-1.34.21-PM.png","caption":"Donny Seyfer"},"description":"Donny is the co-owner of Seyfer Automotive Inc. in Wheat Ridge, CO. Donny is an ASE Master and L1 Advanced Diagnostic Certified Technician, ASE Certified Service Consultant, AMI Accredited Automotive Manager, and the current Automotive Service Association chairman.","url":"https://www.underhoodservice.com/author/dseyfer/"}]}</script>


<script type="text/plain" data-consent-category="Tracking" type='text/javascript'>
(function(p,u,s,h) {
    p._pcq = p._pcq || [];
    p._pcq.push(['_currentTime', Date.now()]);
    s = u.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = 'https://cdn.pushcrew.com/js/ca9bd54ba600c1e9ac67b25b823c3175.js';
    h = u.getElementsByTagName('script')[0]; h.parentNode.insertBefore(s, h);
})(window,document);
</script>

<link rel='dns-prefetch' href='//kit.fontawesome.com' />
<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="UnderhoodService &raquo; Feed" href="https://www.underhoodservice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="UnderhoodService &raquo; Comments Feed" href="https://www.underhoodservice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="UnderhoodService &raquo; Using J2534 Programming Devices Comments Feed" href="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s19539.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://s19539.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cweb-style-css' href='https://s19539.pcdn.co/wp-content/plugins/custom-webinars/css/style.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='ql-bootstrap-css' href='//maxcdn.bootstrapcdn.com/bootstrap/4.1.3/css/bootstrap.min.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='ql-main-css' href='https://s19539.pcdn.co/wp-content/plugins/jawn-alp//styles/main.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn/style.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='bootstrap-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/bootstrap.min.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='barta-box-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/barta-box.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='barta-grid-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/barta-grid.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='barta-list-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/barta-list.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='barta-tab-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/barta-tab.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='ticker-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/ticker-style.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/elementor.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='owl-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/owl.carousel.min.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='owl-theme-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/css/owl.theme.default.min.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/magnific-popup.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='post-sidebar-css-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/post-sidebar.css?ver=1.34' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar-video-widget-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/video-widget.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-child-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/style.css?ver=1.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='bcxwoo-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/woostyle.css?ver=1.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='bcxstrap-style-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/bcx-strap.css?ver=1.0.13' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css' href='//fonts.googleapis.com/css?family=Open+Sans%3A700%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CPT+Serif%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CMontserrat%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css' href='https://s19539.pcdn.co/wp-content/themes/jawn/css/media-queries.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<link rel='stylesheet' id='jawn-sidebar-menu-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/sidebar-menu.css?ver=5.8.4' type='text/css' media='all' />
<style id='jawn-sidebar-menu-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script src="https://kit.fontawesome.com/26ccd13627.js?ver=fa28bd4b4e56a2a24e087252b51f95e6" crossorigin="anonymous" type="text/javascript"></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/js/owl.carousel.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='owl-js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/js/jquery.nivo.slider.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='nivo-slider-js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/js/jquery.ticker.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='ticker-js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/js/script.js?ver=1.74' id='script-js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/js/magnific-popup.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='magnific-popup-js-js'></script>
<script type="text/plain" data-consent-category="Advertising" src='https://cdn.broadstreetads.com/init-2.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='broadstreet-cdn-js'></script>
<script type="text/plain" data-consent-category="Advertising" id='broadstreet-cdn-js-after'>
    function broadstreet_ad_check(zoneId, data) {
        var ads = document.getElementsByTagName("broadstreet-zone");
        for (var i = 0; i < ads.length; i++) {
            var zone = ads[i].getAttribute('zone-id');
            //if this zone get rid of container if empty
            if (zone == zoneId) {
                if ( ads[i].closest(".bcx-ad-wrap") != null && (ads[i].innerHTML === "" || ads[i].getElementsByTagName('div')[0].innerHTML === "") ) {
                    ads[i].closest(".bcx-ad-wrap").style.display = "none";
                    //also get rid of widget container boarders
                    if (ads[i].closest(".bcx_ad_widget") != null) {
                        ads[i].closest(".bcx_ad_widget").style.display = "none";
                    }
                } else if ( ads[i].closest(".bcx-ad-wrap") != null ) {
                    //ensures ads get displayed
                    ads[i].closest(".bcx-ad-wrap").style.display = "inline-block";
                    //also get rid of widget container boarders
                    if (ads[i].closest(".bcx_ad_widget") != null) {
                        ads[i].closest(".bcx_ad_widget").style.display = "block";
                    }
                }
            }
        }
        resize_iframe_ads();
    }
    
    function broadstreet_init() {
        if(typeof broadstreet=='undefined') {
            setTimeout(function(){broadstreet_init()},100);
            return;
        }
        broadstreet.watch({"networkId": "6214", "callback": "broadstreet_ad_check"});
    }
    broadstreet_init();
    
</script>
<link rel="https://api.w.org/" href="https://www.underhoodservice.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.underhoodservice.com/wp-json/wp/v2/posts/188842" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.underhoodservice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s19539.pcdn.co/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.underhoodservice.com/?p=188842' />
<link rel="alternate" type="application/json+oembed" href="https://www.underhoodservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.underhoodservice.com%2Fusing-j2534-programming-devices%25ef%25bf%25bc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.underhoodservice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.underhoodservice.com%2Fusing-j2534-programming-devices%25ef%25bf%25bc%2F&#038;format=xml" />
<style>
        .getty.aligncenter {
            text-align: center;
        }
        .getty.alignleft {
            float: none;
            margin-right: 0;
        }
        .getty.alignleft > div {
            float: left;
            margin-right: 5px;
        }
        .getty.alignright {
            float: none;
            margin-left: 0;
        }
        .getty.alignright > div {
            float: right;
            margin-left: 5px;
        }
        </style>
<script type="text/plain" data-consent-category="Tracking" src="//cdn.freshmarketer.com/144612/337510.js"></script> <style type="text/css" id="wp-custom-css">
			.magazine-past-issue {
    max-width: 112px;
}

.bcx-blog-story-in {
    position: static;
}

.mvp-auto-post-main .bcx-author-container.no-excerpt {
    margin-top: 15px;
}

.template-featured-2 .mvp-post-img {
	margin-bottom: 20px;
}

.template-featured-2 .mvp-post-head-wrap {
    padding-bottom: 0;
}

.template-featured-2 h1.mvp-post-title {
    font-family: 'Anton', sans-serif;
    font-weight: 400;
    font-size: 2.2em;
    text-transform: capitalize;
    text-decoration: none;
    font-size: 3.1rem;
    line-height: 1.15;
    max-width: 740px;
}

.textwidget div.andoto-embed-video,
.textwidget div.andoto-embed-video div {
    float: none;
}
.bcx_recent_single_widget .video-title {
    position: absolute;
    bottom: 2px;
    padding: 10px;
    color: #ffffff;
    background-color: rgba(0,0,0,.4);
    width: 100%;
}
/* SIDE WIDGET - VIDEO PLUS POST - ACDelco - text color*/
#garage_studio_widget-5 .bcx-center .garage-studio-video-wrap .gs-video-wrap h5 a,#garage_studio_widget-5 h3.title-medium-dark a,#garage_studio_widget-5 p.excerpt-medium-dark.size-md.mb-none{
	color: #FFF ;
}
#garage_studio_widget-5 .bcx-center .garage-studio-video-wrap .gs-video-wrap{
	margin-bottom: 1.7em;
}
#garage_studio_widget-5 h3.title-medium-dark a,#garage_studio_widget-5 p.excerpt-medium-dark.size-md.mb-none{
	padding-left: 1em
}
@media (max-width: 767px) {
		.fly-out-footer-menu {
        padding: 0 0 20px;
    }

    span.mvp-fly-soc-head {
        margin-bottom: 5px;
    }

    #mvp-fly-soc-wrap {
        bottom: 50px;
        background-color: #f5f5f5;
    }
	
    .mvp-widget-listing .mvp-blog-story-text h2 {
        padding-left: 10px;
        padding-bottom: 15px;
        line-height: 20px;
    }

    .el-rt-cat.style_2 {
        position: absolute;
        padding: 0 5px !important;
        display: block;
        text-align: center;
    }

    .elementor-column-wrap.elementor-element-populated .elementor-column-wrap.elementor-element-populated {
        padding: 0 !important;
    }
} 

@media (max-width: 479px) {
    .rt-news-list-1.general .item-shadow-gray {
        flex-flow: column;
    }

    .list-default .image-left {
        width: 100%;
    }

    .el-rt-cat.style_2 {
        position: absolute;
    }

    .mvp-blog-story-reg .mvp-blog-story-in {
        grid-template-columns: 120px auto;
    }
}
@media (max-width: 767px) {
.bcx-feat1-main, .bcx-feat1-sub-container {
    width: 100%;
    float: left;
}
}

#mvp-foot-wrap {
	display: block;
	position: relative;
}


/* sneaker offset fix */
.bs-slide-in-code-container {
	margin-left: 50px;
	padding: 20px 0px !important;
}

@media min-width(1200px) {
	.bs-slide-in-code-container {
	  margin-left: 50px;
  }
}		</style>
</head>
<body class="post-template-default single single-post postid-188842 single-format-standard elementor-default elementor-kit-153712">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;"><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB"><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg> 
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W7XCV9K"
		height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script>console.log('Site: https://www.underhoodservice.com')</script>
<div class="mvp-fly-fade mvp-fly-but-click sticky-navbar-fade"></div>
<div class="sticky-navbar">
<div class="navbar-container bottom-offset-0 bottom-offset-lg-0 thin-scroll">
<div class="navbar-branding d-flex">
<a href="https://www.underhoodservice.com">
<img class="navbar-logo" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Babcox-B-Logo.png" />
</a>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center hamburger" data-sidebar=".menu-sidebar">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-sidebar" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/hamburger.png);"></span>

</button>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center navbar-mobile-only " data-sidebar=".search-sidebar" title="Search">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-search" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/search.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Search</div>
 </div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".video-sidebar" title="Video">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-video" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/video.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Video</div>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".webinar-sidebar" title="Webinars">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-webinar" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/webinars.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Webinars</div>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".products-sidebar" title="Products">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-products" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/products.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Products</div>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".podcast-sidebar" title="Podcasts">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-podcast" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/10/CD-Podcasts-logo-UHS.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Podcasts</div>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".digital-edition-sidebar" title="Digital Edition">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-digital-edition" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/digital-edition.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Digital Edition</div>
</div>
</div>
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  " data-sidebar=".login-sidebar" title="Subscribe">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-login" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/subscribe.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Subscribe</div>
</div>
</div>
<a href="/contact/">
<div class="navbar-toggle-button d-flex justify-content-center align-items-center navbar-mobile-only navbar-button-only" data-sidebar=".contact-us-sidebar" title="Contact Us">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-contact-us" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/contact.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Contact Us</div>
</div>
</div>
</a>
<a href="https://www.shopownermag.com/" rel="noopener noreferrer" target="_blank">
<div class="navbar-toggle-button d-flex justify-content-center align-items-center  navbar-button-only" data-sidebar=".shopowner-sidebar" title="Shop Owner">
<div>
<button class="button-toggle">
<span class="navbar-toggle navbar-toggle-shopowner" style="background-image: url(https://s19539.pcdn.co/wp-content/uploads/2021/09/SO-icon.png);"></span>
</button>
<div class="navbar-title row col-12 px-1 no-gutters d-lg-inline-block d-none text-center">Shop Owner</div>
</div>
</div>
</a>
<div class="navbar-toggle-button nav-fill-element"></div>
</div>
<div class="nav-sidebar-bottom">
</div>
<aside class="nav-sidebar menu-sidebar">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button> <div class="row no-gutters d-flex d-lg-none"><div class="col-12 py-3 px-4"><a href="https://www.underhoodservice.com/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a></div></div>
<div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left">
<div id="mvp-fly-wrap">
<div id="mvp-fly-menu-wrap">
<nav class="mvp-fly-nav-menu">
<div class="menu-fly-out-menu-container"><ul id="menu-fly-out-menu" class="menu"><li id="menu-item-153336" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153336"><a href="https://www.underhoodservice.com/category/engine/">Engine</a>
<ul class="sub-menu">
<li id="menu-item-153337" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153337"><a href="https://www.underhoodservice.com/category/engine/internal-engine/">Internal Engine</a></li>
<li id="menu-item-153338" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153338"><a href="https://www.underhoodservice.com/category/engine/external-engine/">External Engine</a></li>
<li id="menu-item-153339" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153339"><a href="https://www.underhoodservice.com/category/engine/engine-electronic/">Electronic</a></li>
</ul>
</li>
<li id="menu-item-153340" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153340"><a href="https://www.underhoodservice.com/category/heating-cooling/">Heating / Cooling</a>
<ul class="sub-menu">
<li id="menu-item-153341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153341"><a href="https://www.underhoodservice.com/category/heating-cooling/heating-cooling-engine/">Engine Compartment</a></li>
<li id="menu-item-153342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153342"><a href="https://www.underhoodservice.com/category/heating-cooling/heating-cooling-passenger/">Passenger Compartment</a></li>
</ul>
</li>
<li id="menu-item-153343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153343"><a href="https://www.underhoodservice.com/category/flow/">Flow</a>
<ul class="sub-menu">
<li id="menu-item-153344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153344"><a href="https://www.underhoodservice.com/category/flow/fuel-flow/">Fuel</a></li>
<li id="menu-item-153345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153345"><a href="https://www.underhoodservice.com/category/flow/oil/">Oil</a></li>
<li id="menu-item-153346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153346"><a href="https://www.underhoodservice.com/category/flow/coolant/">Coolant</a></li>
<li id="menu-item-153347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153347"><a href="https://www.underhoodservice.com/category/flow/air-flow/">Air</a></li>
</ul>
</li>
<li id="menu-item-153348" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-153348"><a href="https://www.underhoodservice.com/category/diagnostic/">Diagnostics</a></li>
<li id="menu-item-153351" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153351"><a href="https://www.underhoodservice.com/category/emerging-technology/">Emerging</a>
<ul class="sub-menu">
<li id="menu-item-153352" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153352"><a href="https://www.underhoodservice.com/category/emerging-technology/emerging-electric/">Electric</a></li>
<li id="menu-item-153353" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153353"><a href="https://www.underhoodservice.com/category/emerging-technology/hybrids/">Hybrid</a></li>
<li id="menu-item-153354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153354"><a href="https://www.underhoodservice.com/category/emerging-technology/emerging-diesel/">Diesel</a></li>
</ul>
</li>
<li id="menu-item-153355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153355"><a href="https://www.underhoodservice.com/category/emissions-2/">Emissions</a>
<ul class="sub-menu">
<li id="menu-item-153357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153357"><a href="https://www.underhoodservice.com/category/emissions-2/exhaust/">Exhaust</a></li>
</ul>
</li>
<li id="menu-item-153358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153358"><a href="https://www.underhoodservice.com/category/featured/">Featured</a></li>
<li id="menu-item-153359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153359"><a href="https://www.underhoodservice.com/category/news/">News</a></li>
<li id="menu-item-153360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153360"><a href="https://www.underhoodservice.com/category/opinion/">Opinion</a></li>
<li id="menu-item-154334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154334"><a href="https://www.aapexshow.com/">AAPEX Show</a></li>
<li id="menu-item-153361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153361"><a href="https://www.underhoodservice.com/category/sponsored-content/">Sponsored Content</a></li>
<li id="menu-item-157203" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157203"><a href="http://www.babcox.com/contributor-portal/shop-owner-portal/">Content Submission</a></li>
</ul></div> </nav>
<div class="row">
<div class="social col-12 text-center my-4">
<span class="bcx-fly-soc-head mb-2">Connect with us</span>
<ul class="sidebar-soc-list">
<li><a href="https://www.facebook.com/UnderhoodService" target="_blank" class="fab fa-facebook-square"></a></li>
<li><a href="https://twitter.com/underhoodserv" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://instagram.com/babcox_underhood" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://www.youtube.com/channel/UCA7Yzkz8Q55bfKSk9SnYPTw" target="_blank" class="fab fa-youtube"></a></li>
<li><a href="https://www.linkedin.com/showcase/underhood-service" target="_blank" class="fab fa-linkedin-in"></a></li>
</ul>
</div>
</div>
<div class="ad col-12 p-0 text-center">
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id="76779"></broadstreet-zone>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="nav-sidebar-right d-none d-lg-block">
<div class="row">
<div class="col-xl-7 col-12">
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-12">
<a href="https://www.underhoodservice.com/read-your-copy-of-the-june-digital-edition-now/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/ShopOwner-digital-edition-June-2022-copy-2.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/featured/"><span class="category">Featured</span></a>
</div>
</div>
<div class="title col-12 mt-2">
<a href="https://www.underhoodservice.com/read-your-copy-of-the-june-digital-edition-now/">Read Your Copy of the June Digital Edition Now</a>
</div>
<div class="excerpt col-12 mt-2">
The new issue of ShopOwner magazine is now available to read online or download at no charge to you!	</div>
</div>
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-12">
<a href="https://www.underhoodservice.com/the-may-digital-edition-is-now-available-to-download-read/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/ShopOwner-digital-edition-May-2022-copy.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/featured/"><span class="category">Featured</span></a>
</div>
</div>
<div class="title col-12 mt-2">
<a href="https://www.underhoodservice.com/the-may-digital-edition-is-now-available-to-download-read/">The May Digital Edition Is Now Available To Download, Read</a>
</div>
<div class="excerpt col-12 mt-2">
ShopOwner includes technical and management content and is free to download and read.	</div>
</div><div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/fuel-tanks-and-pumps/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/Saddle-Style-Fuel-Tanks.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/flow/fuel-flow/"><span class="category">Fuel</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/fuel-tanks-and-pumps/">Fuel Tanks and Pumps</a>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/curing-springtime-air-conditioning-smells/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/04/Curing-Spring-AC-Smells.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/heating-cooling/"><span class="category">Heating / Cooling</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/curing-springtime-air-conditioning-smells/">Curing Springtime Air Conditioning Smells</a>
</div>
</div>
</div>
<div class="recent-posts row d-none d-xl-flex col-5">
<div class="news"><p class="category-title"><a href="https://www.underhoodservice.com/category/news/">News <span class="arrow"><i class="fas fa-long-arrow-right"></i></span></a></p><div class="sidebar-post single row no-gutters mb-4">
<div class="author col-12 mb-2">
Jun 22, 2022	</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/gfs-lincoln-tech-partner-for-collision-repair-tech-training/">GFS, Lincoln Tech Partner For Collision Repair Training</a>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="author col-12 mb-2">
Jun 21, 2022	</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/mobile-tech-connects-students-with-companies-at-skillsusa/">Mobile Tech Connects Students With Companies at SkillsUSA</a>
</div>
</div>
</div><p class="category-title"><a href="https://www.underhoodservice.com/category/emerging-technology/">Emerging <span class="arrow"><i class="fas fa-long-arrow-right"></i></span></a></p><div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/hv-ev-lifting-guidelines/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/lifting-ev-and-hybrid-cars.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/emerging-technology/hybrids/"><span class="category">Hybrid</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/hv-ev-lifting-guidelines/">HV/EV Lifting Guidelines</a>
</div>
</div>
<p class="category-title"><a href="https://www.underhoodservice.com/category/diagnostic/">Diagnostics <span class="arrow"><i class="fas fa-long-arrow-right"></i></span></a></p><div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/diagnostic/"><span class="category">Diagnostics</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/">Using J2534 Programming Devices</a>
</div>
</div>
<p class="category-title"><a href="https://www.underhoodservice.com/category/engine/">Engine <span class="arrow"><i class="fas fa-long-arrow-right"></i></span></a></p><div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/diagnosing-driveability-problems/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/Engine-diagnostics.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/engine/"><span class="category">Engine</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/diagnosing-driveability-problems/">Diagnosing Driveability Problems</a>
</div>
</div>
</div>
</div>
</div>
</div>
</aside>
<aside class="nav-sidebar search-sidebar navbar-thin">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-right full-width d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
</div>

<div class="row no-gutters mb-3 d-none d-lg-flex">
<div class="col-12">
<div class="sidebar-search no-gutters row">
<div class="search col-12 mt-4 mt-lg-0 mb-4">
<form role="search" class="d-flex" method="get" action="https://www.underhoodservice.com/">
<div class="form-group flex-fill mb-0 has-feedback">
<input id="s" type="text" class="form-control h-100" placeholder="Search" value="" name="s">
</div>
</form>
</div>
<div class="popular col-12 mb-3">
<h3>Popular Posts</h3>
<p class="title mb-2"><a href="https://www.underhoodservice.com/diagnosing-driveability-problems/">Diagnosing Driveability Problems</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/">Improve Diagnostic Skills By Listening Better</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/turbocharger-topics/">Turbocharger Topics</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/tech-tip-no-start-in-cold-weather-due-to-no-weep-hole/">Tech Tip: No Start in Cold Weather Due to No Weep Hole</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/protect-your-fuel-tank-and-pump-with-delphi-technologies/">Protect Your Fuel Tank and Pump With Delphi Technologies </a></p>
</div>
<div class="ad col-12 text-center mb-3">
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id="76779"></broadstreet-zone>
</div>
</div>
</div>
<div class="social col-12 text-center mb-3">
<span class="bcx-fly-soc-head mb-2">Connect with us</span>
<ul class="sidebar-soc-list">
<li><a href="https://www.facebook.com/UnderhoodService" target="_blank" class="fab fa-facebook-square"></a></li>
<li><a href="https://twitter.com/underhoodserv" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://instagram.com/babcox_underhood" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://www.youtube.com/channel/UCA7Yzkz8Q55bfKSk9SnYPTw" target="_blank" class="fab fa-youtube"></a></li>
<li><a href="https://www.linkedin.com/showcase/underhood-service" target="_blank" class="fab fa-linkedin-in"></a></li>
</ul>
</div>
<div class="advertise col-12 text-center">
<a href="http://www.babcox.com/brand/underhood-service/">advertise with us <span class="inline-arrow"><i class="fas fa-long-arrow-right"></i></span></a>
</div>
</div>
</div>
</div>

<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="row no-gutters mb-3">
<div class="col-12">
<div class="sidebar-search no-gutters row">
<div class="search col-12 mt-4 mt-lg-0 mb-4">
<form role="search" class="d-flex" method="get" action="https://www.underhoodservice.com/">
<div class="form-group flex-fill mb-0 has-feedback">
<input id="s" type="text" class="form-control h-100" placeholder="Search" value="" name="s">
</div>
</form>
</div>
<div class="popular col-12 mb-3">
<h3>Popular Posts</h3>
<p class="title mb-2"><a href="https://www.underhoodservice.com/diagnosing-driveability-problems/">Diagnosing Driveability Problems</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/">Improve Diagnostic Skills By Listening Better</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/turbocharger-topics/">Turbocharger Topics</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/tech-tip-no-start-in-cold-weather-due-to-no-weep-hole/">Tech Tip: No Start in Cold Weather Due to No Weep Hole</a></p>
<p class="title mb-2"><a href="https://www.underhoodservice.com/protect-your-fuel-tank-and-pump-with-delphi-technologies/">Protect Your Fuel Tank and Pump With Delphi Technologies </a></p>
</div>
<div class="ad col-12 text-center mb-3">
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id="76779"></broadstreet-zone>
</div>
</div>
</div>
<div class="social col-12 text-center mb-3">
<span class="bcx-fly-soc-head mb-2">Connect with us</span>
<ul class="sidebar-soc-list">
<li><a href="https://www.facebook.com/UnderhoodService" target="_blank" class="fab fa-facebook-square"></a></li>
<li><a href="https://twitter.com/underhoodserv" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://instagram.com/babcox_underhood" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://www.youtube.com/channel/UCA7Yzkz8Q55bfKSk9SnYPTw" target="_blank" class="fab fa-youtube"></a></li>
<li><a href="https://www.linkedin.com/showcase/underhood-service" target="_blank" class="fab fa-linkedin-in"></a></li>
</ul>
</div>
<div class="advertise col-12 text-center">
<a href="http://www.babcox.com/brand/underhood-service/">advertise with us <span class="inline-arrow"><i class="fas fa-long-arrow-right"></i></span></a>
</div>
</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar video-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left d-none d-lg-block">
<div class="row no-gutters d-flex pb-3"><div class="col-12"><a href="https://www.underhoodservice.com/category/original-video/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Video-Category-Image.png"></a></div></div>
<div class="nav-sidebar-video-posts elementor">
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/lubegard.jpg">
</div>
<div class="overlay">
<div class="img d-flex justify-content-center align-items-center">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png">
</div>
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/original-video/"><span class="category">Video</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">GM Eight Speed Torque Converter Shudder Solution (VIDEO)</a>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/understanding-autel-its600-functions-video/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/autel.jpg">
</div>
<div class="overlay">
<div class="img d-flex justify-content-center align-items-center">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png">
</div>
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/original-video/"><span class="category">Video</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/understanding-autel-its600-functions-video/">Understanding The Autel ITS600 Functions (VIDEO)</a>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/auto-pros-visit-am-auto-service-pineville-nc/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/auto-pros-post.jpg">
</div>
<div class="overlay">
<div class="img d-flex justify-content-center align-items-center">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png">
</div>
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/original-video/auto-pros-on-the-road/"><span class="category">Auto Pros on the Road</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/auto-pros-visit-am-auto-service-pineville-nc/">Auto Pros Visit A&amp;M Auto Service, Pineville, NC</a>
</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/original-video/">click here for more</a></div></div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id=""></broadstreet-zone>
</div>
</div>
</div>
<div class="nav-sidebar-right  d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
<div class="nav-sidebar-section-head mb-2">Featured Video</div>
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-12">
<div id="featured-post-video" class="featured-post-video" data-video_id="Ri6VjRQl">
<script src="https://cdn.jwplayer.com/libraries/NJFp4RYM.js"></script>
<script type="text/javascript">
                jwplayer('featured-post-video').setup({
                    file: 'https://content.jwplatform.com/videos/Ri6VjRQl-720.mp4',
                    image: 'https://content.jwplatform.com/thumbs/Ri6VjRQl-720.jpg',
                    width: '100%',
                    aspectratio: '16:9'
                });
            </script>
</div>
</div>
<div class="title col-12 mt-2">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/">Cooling System: Hose Inspection and Replacement</a>
</div>
<div class="excerpt col-12 mt-2">
One bad hose can cause an engine malfunction. This video is sponsored by Continental.	</div>
</div> </div>

<div class="row no-gutters mb-3 d-none d-lg-flex">
<div class="col-12">

<figure class="wp-block-image size-large"><a href="/tag/acdelcotv"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200.jpg" alt="" class="wp-image-187622" /></a></figure>
</div>
</div>

<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/category/original-video/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Video-Category-Image.png"></a></div></div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/Screen-Shot-2022-06-20-at-3.11.38-PM.png">
</div>
<div class="overlay">
<div class="img d-flex justify-content-center align-items-center">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png">
</div>
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/original-video/"><span class="category">Video</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/">Cooling System: Hose Inspection and Replacement</a>
</div>
</div>
<div class="row no-gutters mb-3">
<div class="col-12">

<figure class="wp-block-image size-large"><a href="/tag/acdelcotv"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200.jpg" alt="" class="wp-image-187622" /></a></figure>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/lubegard.jpg">
</div>
<div class="overlay">
<div class="img d-flex justify-content-center align-items-center">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png">
</div>
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/original-video/"><span class="category">Video</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">GM Eight Speed Torque Converter Shudder Solution (VIDEO)</a>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/original-video/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar webinar-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left d-none d-lg-block">
<div class="row no-gutters d-flex pb-3"><div class="col-12"><a href="/webinars/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="nav-sidebar-video-posts elementor">
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">No Code Drivability Diagnostic Strategies For BMW, Mercedes and VW/Audi</a>
</div>
<div class="webinar-content col-12 mb-2">
<p class="register "><span class="on-demand">On-Demand Webinar</span></p>
<p class="air-date"><span class="font-weight-bold">Original Air Date:</span> June 15, 2022</p>
<p class="">Sponsored By AAPEX</p>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a target="_blank" href="https://webinars.on24.com/babcox/ACsystems?partnerref=/UHSwebsite">Dealing With Overcharged and Contaminated AC Systems</a>
</div>
<div class="webinar-content col-12 mb-2">
<p class="register "><span class="on-demand">On-Demand Webinar</span></p>
<p class="air-date"><span class="font-weight-bold">Original Air Date:</span> June 09, 2022</p>
<p class="">Sponsored By Transtar AC</p>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">Hiring and Retaining Great Employees</a>
</div>
<div class="webinar-content col-12 mb-2">
<p class="register "><span class="on-demand">On-Demand Webinar</span></p>
<p class="air-date"><span class="font-weight-bold">Original Air Date:</span> May 23, 2022</p>
<p class="">Sponsored By AAPEX</p>
</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="/webinars/">click here for more</a></div></div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id=""></broadstreet-zone>
</div>
</div>
</div>
<div class="nav-sidebar-right  d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
<div class="nav-sidebar-section-head mb-2">Featured Webinar</div>
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-6 mb-2">
<a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/AAPEX-Part-6-600x300-1.jpg">
</div>
</a>
</div>
<div class="title col-6 mb-2">
<p class="title"><a href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">Service Advisors: Customer Satisfaction Starts With Communication</a></p>
<p class="air-date"><span class="font-weight-bold">Air Date:</span> June 28, 2022</p>
<p class="register"><span class="register"><a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">Register Now <span class="arrow"><i class="fas fa-long-arrow-right"></i></span></a></span></p>
</div>
<div class="webinar-content col-12">
<p class="text-center">Sponsored By AAPEX</p>
<p class="description"><p>This webinar is part of "AAPEX Repair Shop HQ Webinar Series: An 8-Part Webinar Series." Sponsored by AAPEX.</p>
<p>Your first encounter with a customer is a lasting one – are your service advisors’ communication skills up to the task? We’ll outline the top tips to ensure that every conversation on the phone, in person and via text helps set the appointment, confirm the service request, complete the payment, and confirm any follow-up service requirements.</p>
</p>
<p class="speakers"><span class="font-weight-bold">Speakers</span><br><ul>
<li><span class="sp-name">Doug Kaufman, </span><span class="sp-title">Editor, </span><span class="sp-company">ShopOwner</span></li>
</ul></p>
</div>
</div> </div>


<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="/webinars/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">Service Advisors: Customer Satisfaction Starts With Communication</a>
</div>
<div class="webinar-content col-12 mb-2">
<p class="register "><a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite"><span class="register">Register Now <span class="arrow"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Arrow.png"></span></span></a></p>
<p class="air-date"><span class="font-weight-bold">Air Date:</span> June 28, 2022</p>
<p class="">Sponsored By AAPEX</p>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a target="_blank" href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite">No Code Drivability Diagnostic Strategies For BMW, Mercedes and VW/Audi</a>
</div>
<div class="webinar-content col-12 mb-2">
<p class="register "><span class="on-demand">On-Demand Webinar</span></p>
<p class="air-date"><span class="font-weight-bold">Original Air Date:</span> June 15, 2022</p>
<p class="">Sponsored By AAPEX</p>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="/webinars/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar products-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left d-none d-lg-block">
<div class="row no-gutters d-flex pb-3"><div class="col-12"><a href="https://www.underhoodservice.com/category/products/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Products-Category-Image.png"></a></div></div>
<div class="nav-sidebar-video-posts elementor">
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/launch-releases-x-431-adas-pro-plus/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/ADAS-pro-plus.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/launch-releases-x-431-adas-pro-plus/">Launch Releases X-431 ADAS PRO PLUS</a>
</div>
<div class="excerpt col-12">
The X-431 ADAS PRO PLUS is the third-generation professional ADAS system calibration stand for passenger cars.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/aisin-expands-window-regulator-line/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/Window-Regulators.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/aisin-expands-window-regulator-line/">AISIN Expands Window Regulator Line</a>
</div>
<div class="excerpt col-12">
The product launch includes Asian, domestic and European applications.
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/milwaukee-tool-offers-new-high-speed-ratchets/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/04/Milwaukee-ratchet.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/milwaukee-tool-offers-new-high-speed-ratchets/">Milwaukee Tool Offers New High Speed Ratchets</a>
</div>
<div class="excerpt col-12">
The POWERSTATE Brushless Motor delivers up to 35% faster speeds and 35 ft.-lbs., ensuring power that rivals pneumatic.	</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/products/">click here for more</a></div></div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id="83465"></broadstreet-zone>
</div>
</div>
</div>
<div class="nav-sidebar-right  d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
<div class="bcx-ad-wrap mb-4">

<div class="bcx-ad-content leaderboard">
<broadstreet-zone zone-id="76780"></broadstreet-zone>
</div>
</div>
<div class="nav-sidebar-section-head mb-2">Product Video Spotlight</div>
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-12">
<a href="https://www.underhoodservice.com/autel-u-s-enters-ev-charging-solutions-industry%ef%bf%bc/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/MaxiCharger-AC-Family-copy.png">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mt-2">
<a href="https://www.underhoodservice.com/autel-u-s-enters-ev-charging-solutions-industry%ef%bf%bc/">Autel U.S. Enters EV Charging Solutions Industry</a>
</div>
<div class="excerpt col-12 mt-2">
Autel U.S. announces two new EV charging solutions both for home and commercial use.	</div>
</div> </div>


<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/category/products/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Products-Category-Image.png"></a></div></div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/autel-u-s-enters-ev-charging-solutions-industry%ef%bf%bc/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/MaxiCharger-AC-Family-copy.png">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/autel-u-s-enters-ev-charging-solutions-industry%ef%bf%bc/">Autel U.S. Enters EV Charging Solutions Industry</a>
</div>
<div class="excerpt col-12">
Autel U.S. announces two new EV charging solutions both for home and commercial use.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/launch-releases-x-431-adas-pro-plus/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/ADAS-pro-plus.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/launch-releases-x-431-adas-pro-plus/">Launch Releases X-431 ADAS PRO PLUS</a>
</div>
<div class="excerpt col-12">
The X-431 ADAS PRO PLUS is the third-generation professional ADAS system calibration stand for passenger cars.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="img-container col-12 mb-2">
<a href="https://www.underhoodservice.com/aisin-expands-window-regulator-line/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/Window-Regulators.jpg">
</div>
</a>
<div class="category">
<a href="https://www.underhoodservice.com/category/products/"><span class="category">Products</span></a>
</div>
</div>
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/aisin-expands-window-regulator-line/">AISIN Expands Window Regulator Line</a>
</div>
<div class="excerpt col-12">
The product launch includes Asian, domestic and European applications.
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/products/">click here for more</a></div></div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content leaderboard">
<broadstreet-zone zone-id="76780"></broadstreet-zone>
</div>
</div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar podcast-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left d-none d-lg-block">
<div class="row no-gutters d-flex pb-3"><div class="col-12"><a href="https://www.underhoodservice.com/category/podcasts/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Podcasts-Category-Image.png"></a></div></div>
<div class="nav-sidebar-video-posts elementor">
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a href="https://www.underhoodservice.com/innovative-marketing-options-bridge-communication-gaps/">Innovative Marketing Options Bridge Communication Gaps</a>
</div>
<div class="excerpt col-12">
Marketing partnerships can go a long way toward easing shop stress. This episode is sponsored by Advance Professional.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a href="https://www.underhoodservice.com/shop-veterans-share-secrets-to-keep-business-plans-afloat/">Shop Veterans Share Secrets to Keep Business Plans Afloat</a>
</div>
<div class="excerpt col-12">
Shop Owner Solutions is a lifeline to help shop owners understand the struggles of business - and you're not alone.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a href="https://www.underhoodservice.com/are-todays-graduates-prepared-to-be-tomorrows-tech-pros/">Are Today&#039;s Graduates Prepared To Be Tomorrow&#039;s Tech Pros?</a>
</div>
<div class="excerpt col-12">
With a potential shortage of nearly 650,000 technicians on the horizon, who will fill the openings?	</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/podcasts/">click here for more</a></div></div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id=""></broadstreet-zone>
</div>
</div>
</div>
<div class="nav-sidebar-right  d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
<div class="nav-sidebar-section-head mb-2">Featured Podcast</div>
<div class="sidebar-featured single row mb-4 d-flex justify-content-center align-items-center">
<div class="img-container col-12">
<iframe src="https://widget.spreaker.com/player?episode_id=50123803&amp;theme=light&amp;playlist=false&amp;playlist-continuous=false&amp;chapters-image=true&amp;episode_image_position=right&amp;hide-likes=false&amp;hide-comments=false&amp;hide-sharing=false&amp;hide-logo=false&amp;hide-download=true" width="100%" height="200px" frameborder="0"></iframe> </div>
<div class="title col-12 mt-2">
<a href="https://www.underhoodservice.com/transtars-neil-sethi-from-healthcare-to-hard-parts-podcast/">Transtar’s Neil Sethi, from Healthcare to Hard Parts (Podcast)</a>
</div>
<div class="excerpt col-12 mt-2">
Throughout his career journey from medicine to an MBA, some key themes prevail for Sethi – the desire to serve and a passion to innovate.	</div>
</div> </div>

<div class="row no-gutters mb-3 d-none d-lg-flex">
<div class="col-12">
<h4 class="has-text-align-center"><span style="color:#ffff33" class="has-inline-color">Follow UHS’s podcast on these platforms!</span></h4>
<div class="row">
<div class="col-4 mb-2">
<a target="_blank" href="https://podcasts.apple.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/apple-podcast-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.google.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/google-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.iheart.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/iheart-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://open.spotify.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/spotify-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.spreaker.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/spreaker-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.stitcher.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/stitcher-white-scaled-1.png"></a>
</div>
</div>
</div>
</div>

<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/category/podcasts/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Podcasts-Category-Image.png"></a></div></div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<a href="https://www.underhoodservice.com/transtars-neil-sethi-from-healthcare-to-hard-parts-podcast/">Transtar’s Neil Sethi, from Healthcare to Hard Parts (Podcast)</a>
</div>
<div class="excerpt col-12">
Throughout his career journey from medicine to an MBA, some key themes prevail for Sethi – the desire to serve and a passion to innovate.	</div>
</div>
<div class="row no-gutters mb-3">
<div class="col-12">
<h4 class="has-text-align-center"><span style="color:#ffff33" class="has-inline-color">Follow UHS’s podcast on these platforms!</span></h4>
<div class="row">
<div class="col-4 mb-2">
<a target="_blank" href="https://podcasts.apple.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/apple-podcast-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.google.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/google-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.iheart.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/iheart-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://open.spotify.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/spotify-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.spreaker.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/spreaker-white-scaled-1.png"></a>
</div>
<div class="col-4 mb-2">
<a target="_blank" href="https://www.stitcher.com/" rel="noopener noreferrer"><img src="/wp-content/uploads/2021/10/stitcher-white-scaled-1.png"></a>
</div>
</div>
</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a href="https://www.underhoodservice.com/innovative-marketing-options-bridge-communication-gaps/">Innovative Marketing Options Bridge Communication Gaps</a>
</div>
<div class="excerpt col-12">
Marketing partnerships can go a long way toward easing shop stress. This episode is sponsored by Advance Professional.	</div>
</div>
<div class="sidebar-post single row no-gutters mb-4">
<div class="title col-12 mb-2">
<div class="play-container"><div class="small-play d-flex justify-content-center align-items-center"><img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-Play.png"></div></div>
<a href="https://www.underhoodservice.com/shop-veterans-share-secrets-to-keep-business-plans-afloat/">Shop Veterans Share Secrets to Keep Business Plans Afloat</a>
</div>
<div class="excerpt col-12">
Shop Owner Solutions is a lifeline to help shop owners understand the struggles of business - and you're not alone.	</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/category/podcasts/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar digital-edition-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-left d-none d-lg-block">
<div class="row no-gutters d-flex pb-3"><div class="col-12"><a href="/magazine/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="nav-sidebar-video-posts elementor">
<div class="magazine-sidebar-widget">
<h2 class="widget-title">June 2022 Issue</h2>
<div class="magazine-cover-wrap text-center">
<a href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007" target="_blank">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/so.June_.22.CoverSO.jpg" alt="June 2022">
</a>
</div>
<a target="_blank" class="clear-btn widget-btn" href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007">Digital Edition</a>
<a target="_blank" class="clear-btn widget-btn" href="/subscribe">Subscribe Now</a>
<a target="_blank" class="clear-btn widget-btn" href="https://www.underhoodservice.com/magazine/">Magazine Archive</a>
</div>
</div>
<div class="bcx-ad-wrap">

<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id=""></broadstreet-zone>
</div>
</div>
</div>
<div class="nav-sidebar-right  d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
<div class="magazine-archive-widget">
<h2 class="widget-title">In the June 2022 Issue...</h2>
<div class="row magazine-archive-posts-wrap">
<div class="col-sm-6 magazine-archive-post single d-flex justify-content-center align-items-top">
<div class="row">
<div class="img-container col-6">
<a href="https://www.underhoodservice.com/read-your-copy-of-the-june-digital-edition-now/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/ShopOwner-digital-edition-June-2022-copy-2-300x150.jpg">
</div>
</a>
</div>
<div class="title col-6 pl-0">
<a class="post-title" href="https://www.underhoodservice.com/read-your-copy-of-the-june-digital-edition-now/">Read Your Copy of the June Digital Edition Now</a>
</div>
</div>
</div>
<div class="col-sm-6 magazine-archive-post single d-flex justify-content-center align-items-top">
<div class="row">
<div class="img-container col-6">
<a href="https://www.underhoodservice.com/tpms-sensor-signals/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/TPMS-Signal-300x150.jpg">
</div>
</a>
</div>
<div class="title col-6 pl-0">
<a class="post-title" href="https://www.underhoodservice.com/tpms-sensor-signals/">TPMS Sensor Signals</a>
</div>
</div>
</div>
<div class="col-sm-6 magazine-archive-post single d-flex justify-content-center align-items-top">
<div class="row">
<div class="img-container col-6">
<a href="https://www.underhoodservice.com/ethanol-damage-to-fuel-pumps/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/E-15-Gasoline-300x150.jpg">
</div>
</a>
</div>
<div class="title col-6 pl-0">
<a class="post-title" href="https://www.underhoodservice.com/ethanol-damage-to-fuel-pumps/">Ethanol Damage to Fuel Pumps</a>
</div>
</div>
</div>
<div class="col-sm-6 magazine-archive-post single d-flex justify-content-center align-items-top">
<div class="row">
<div class="img-container col-6">
<a href="https://www.underhoodservice.com/the-changing-vehicle-ownership-cycle/">
<div class="img">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/driving-300x150.jpg">
</div>
</a>
</div>
<div class="title col-6 pl-0">
<a class="post-title" href="https://www.underhoodservice.com/the-changing-vehicle-ownership-cycle/">The Changing Vehicle Ownership Cycle</a>
</div>
</div>
</div>
</div>
<div class="magazine-archive-bottom">
<div class="row">
<div class="col-md-8">
<div class="magazine-past-issue-wrap">
<div class="magazine-past-issue">
<a class="btn-digital-magazine-circ img-link" target="_blank" href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/05/so.MAY_.22.CoverSO.jpg" alt="May 2022">
</a>
<p class="past-issue-title">May 2022</p>
</div>
<div class="magazine-past-issue">
<a class="btn-digital-magazine-circ img-link" target="_blank" href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&edid=ab745331-1a2f-4e01-a234-c2b01a5c8cda">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/04/so.APR_.22.CoverSO.jpg" alt="April 2022">
</a>
<p class="past-issue-title">April 2022</p>
</div>
<div class="magazine-past-issue">
<a class="btn-digital-magazine-circ img-link" target="_blank" href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/03/March-SO-cover-1.png" alt="March 2022">
</a>
<p class="past-issue-title">March 2022</p>
</div>
</div>
</div>
<div class="col-md-4 magazine-archive-button-wrap">
<a target="_blank" class="clear-btn widget-btn" href="https://www.underhoodservice.com/magazine/">Magazine Archive</a>
</div>
</div>
</div>
</div>
</div>


<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="magazine-sidebar-widget">
<h2 class="widget-title">June 2022 Issue</h2>
<div class="magazine-cover-wrap text-center">
<a href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007" target="_blank">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/so.June_.22.CoverSO.jpg" alt="June 2022">
</a>
</div>
<a target="_blank" class="clear-btn widget-btn" href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007">Digital Edition</a>
<a target="_blank" class="clear-btn widget-btn" href="/subscribe">Subscribe Now</a>
<a target="_blank" class="clear-btn widget-btn" href="https://www.underhoodservice.com/magazine/">Magazine Archive</a>
</div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar login-sidebar navbar-thin">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-right full-width d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
</div>

<div class="row no-gutters mb-3 d-none d-lg-flex">
<div class="col-12">


<div class="row no-gutters">
<div class="col-12">
<p style="line-height: 1.2rem;"><i>Underhood Service</i> targets repair shops that derive 50 percent or more of their revenue from the service and repair of under-the-hood systems. The expanding amount of knowledge and capital needed to keep up with technological advances has led these shop owners to concentrate on underhood systems, while also offering preventive maintenance services on most major vehicle systems. By subscribing, you’ll receive the ShopOwner digital edition magazine (12 times/year) featuring articles from Underhood Service and the Underhood Service eNewsletter (twice weekly). Access to digital editions, contests, news, and more are ready for you today!</p>
</div>
</div>
<div class="row no-gutters">
<div class="col-6">
<a target="/subscribe" class="clear-btn subscribe" href="/subscribe" rel="noopener noreferrer">Subscribe</a>
</div>

</div>
</div>
</div>

<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="row no-gutters mb-3">
<div class="col-12">


<div class="row no-gutters">
<div class="col-12">
<p style="line-height: 1.2rem;"><i>Underhood Service</i> targets repair shops that derive 50 percent or more of their revenue from the service and repair of under-the-hood systems. The expanding amount of knowledge and capital needed to keep up with technological advances has led these shop owners to concentrate on underhood systems, while also offering preventive maintenance services on most major vehicle systems. By subscribing, you’ll receive the ShopOwner digital edition magazine (12 times/year) featuring articles from Underhood Service and the Underhood Service eNewsletter (twice weekly). Access to digital editions, contests, news, and more are ready for you today!</p>
</div>
</div>
<div class="row no-gutters">
<div class="col-6">
<a target="/subscribe" class="clear-btn subscribe" href="/subscribe" rel="noopener noreferrer">Subscribe</a>
</div>

</div>
</div>
</div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar contact-us-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-right full-width d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
</div>


<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/">click here for more</a></div></div>
</div>
</div>
</div> </aside> <aside class="nav-sidebar shopowner-sidebar ">
<div class="nav-sidebar-header row no-gutters justify-content-lg-between justify-content-center align-items-center d-none d-lg-flex pb-lg-0 pb-3 site-sponsor">
<div class="site-logo-cont py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" height="90" width="auto" data-rjs="2" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<button class="nav-sidebar-close"><i class="fal fa-times"></i></button><div class="nav-sidebar-body thin-scroll site-sponsor">
<div class="nav-sidebar-right full-width d-block">
<div class="nav-sidebar-desktop d-none d-lg-block">
</div>


<div class="nav-sidebar-mobile d-block d-lg-none">
<div class="row no-gutters"><div class="col-12 py-3"><a href="https://www.underhoodservice.com/"><img class="nav-top-img" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png"></a></div></div>
<div class="row no-gutters d-flex pb-3"><div class="col-12 text-center"><a class="clear-btn widget-btn" href="https://www.underhoodservice.com/">click here for more</a></div></div>
</div>
</div>
</div> </aside> </div>
<div id="mvp-fly-wrap">
<div id="mvp-fly-menu-top" class="left relative">
<div id="mvp-fly-logo" class="left relative">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Babcox-B-Logo.png" alt="UnderhoodService" data-rjs="2" /></a>
</div>
<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="mvp-fly-menu-wrap">
<nav class="mvp-fly-nav-menu left relative with-sponsorship">
<div class="mvp-site-sponsorship-menu-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
<div class="menu-fly-out-menu-container"><ul id="menu-fly-out-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153336"><a href="https://www.underhoodservice.com/category/engine/">Engine</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153337"><a href="https://www.underhoodservice.com/category/engine/internal-engine/">Internal Engine</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153338"><a href="https://www.underhoodservice.com/category/engine/external-engine/">External Engine</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153339"><a href="https://www.underhoodservice.com/category/engine/engine-electronic/">Electronic</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153340"><a href="https://www.underhoodservice.com/category/heating-cooling/">Heating / Cooling</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153341"><a href="https://www.underhoodservice.com/category/heating-cooling/heating-cooling-engine/">Engine Compartment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153342"><a href="https://www.underhoodservice.com/category/heating-cooling/heating-cooling-passenger/">Passenger Compartment</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153343"><a href="https://www.underhoodservice.com/category/flow/">Flow</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153344"><a href="https://www.underhoodservice.com/category/flow/fuel-flow/">Fuel</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153345"><a href="https://www.underhoodservice.com/category/flow/oil/">Oil</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153346"><a href="https://www.underhoodservice.com/category/flow/coolant/">Coolant</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153347"><a href="https://www.underhoodservice.com/category/flow/air-flow/">Air</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-153348"><a href="https://www.underhoodservice.com/category/diagnostic/">Diagnostics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153351"><a href="https://www.underhoodservice.com/category/emerging-technology/">Emerging</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153352"><a href="https://www.underhoodservice.com/category/emerging-technology/emerging-electric/">Electric</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153353"><a href="https://www.underhoodservice.com/category/emerging-technology/hybrids/">Hybrid</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153354"><a href="https://www.underhoodservice.com/category/emerging-technology/emerging-diesel/">Diesel</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-153355"><a href="https://www.underhoodservice.com/category/emissions-2/">Emissions</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153357"><a href="https://www.underhoodservice.com/category/emissions-2/exhaust/">Exhaust</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153358"><a href="https://www.underhoodservice.com/category/featured/">Featured</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153359"><a href="https://www.underhoodservice.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153360"><a href="https://www.underhoodservice.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154334"><a href="https://www.aapexshow.com/">AAPEX Show</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153361"><a href="https://www.underhoodservice.com/category/sponsored-content/">Sponsored Content</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157203"><a href="http://www.babcox.com/contributor-portal/shop-owner-portal/">Content Submission</a></li>
</ul></div> <div class="fly-out-custom-menu fly-out-topics-menu">
<h4 class="mvp-fly-nav-menu-headline">Special Topics</h4>
<div class="menu-special-topics-container"><ul id="menu-special-topics" class="menu"><li id="menu-item-153387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153387"><a href="https://www.underhoodservice.com/webinars/">Webinars</a></li>
<li id="menu-item-153388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153388"><a href="https://www.underhoodservice.com/category/original-video/">Video</a></li>
<li id="menu-item-153389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-153389"><a href="https://www.underhoodservice.com/category/podcasts/">Podcasts</a></li>
</ul></div> </div>
<div class="fly-out-custom-menu fly-out-magazine-menu">
<h4 class="mvp-fly-nav-menu-headline">Magazine</h4>
<div class="menu-popout-magazine-container"><ul id="menu-popout-magazine" class="menu"><li id="menu-item-153385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153385"><a target="_blank" rel="noopener" href="http://digital.underhoodservice.com">Current Issue</a></li>
<li id="menu-item-153386" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153386"><a href="https://www.underhoodservice.com/magazine/">Past Issues</a></li>
</ul></div> </div>
</nav>
</div>
<div id="mvp-fly-soc-wrap">
<span class="mvp-fly-soc-head">Connect with us</span>
<ul class="mvp-fly-soc-list left relative">
<li><a href="https://www.facebook.com/UnderhoodService" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/underhoodserv" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://instagram.com/babcox_underhood" target="_blank" class="fab fa-instagram"></a></li>
<li><a href="https://www.youtube.com/channel/UCA7Yzkz8Q55bfKSk9SnYPTw" target="_blank" class="fab fa-youtube"></a></li>
<li><a href="https://www.linkedin.com/showcase/underhood-service" target="_blank" class="fab fa-linkedin-in"></a></li>
</ul>
</div>
<div class="fly-out-footer-menu">
<div class="menu-popout-footer-container"><ul id="menu-popout-footer" class="menu"><li id="menu-item-153382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153382"><a target="_blank" rel="noopener" href="http://ads.babcox.com/?brand_id=146">Advertise</a></li>
<li id="menu-item-153383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153383"><a target="_blank" rel="noopener" href="/subscribe">Subscribe</a></li>
<li id="menu-item-153397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153397"><a href="https://www.underhoodservice.com/contact/">Contact Us</a></li>
</ul></div> </div>
</div> <div id="mvp-site" class="left relative">
<div id="mvp-site-wall" class="left relative">
<div id="mvp-leader-wrap">
</div>
<div id="mvp-site-main" class="left relative">
<div id="mvp-site-grid">
<header id="mvp-main-head-wrap" class="left relative">
<div class="container p-0">
<div class="row no-gutters">
<div class="row d-flex justify-content-center align-items-center m-auto m-lg-0 float-left">
<div class="d-flex justify-content-center align-items-center site-logo-cont site-sponsor py-1">
<a href="https://www.underhoodservice.com/"><img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" alt="UnderhoodService" /></a>
</div>
<div class="site-sponsor-cont flex-fill d-flex justify-content-lg-start justify-content-center align-items-center text-lg-left text-center p-lg-1 p-0">
<div class="site-sponsorship-top-ad">
<broadstreet-zone zone-id="80154"></broadstreet-zone>
</div>
</div>
</div>
<div class="login-subscribe-search-container d-none d-lg-block ml-auto float-right">
<div class="row no-gutters">
<div class="col-12">
<div class="row no-gutters">
<div class="col-12">
<a target="_blank" class="clear-btn subscribe" href="https://www.underhoodservice.com/subscribe">Subscribe</a>
</div>
</div>
</div>
<div class="col-12">
<form role="search" class="d-flex" method="get" action="https://www.underhoodservice.com/">
<div class="form-group flex-fill mb-0 has-feedback">
<input id="s" type="text" class="form-control h-100 clear-input" placeholder="Search" value="" name="s">
<i class="search-icon fas fa-search"></i>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
<div id="mvp-search-wrap">
<div id="mvp-search-box">
<form method="get" id="searchform" action="https://www.underhoodservice.com/">
<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
<input type="hidden" id="searchsubmit" value="Search" />
</form> </div>
</div>
</header>
<div class="rt-news-ticker-holder">
<div class="container">
<script>
    (function($){
        $(function(){
            if (typeof $.fn.ticker == 'function') {
                $('#rt-js-news').ticker({
                    speed: .10,
                    debugMode: true,
                    controls: '',
                    titleText: 'Under The Wire',
                    displayType: 'reveal',
                    direction: 'ltr',
                    pauseOnItems: 2000,
                });
            } else {
                console.log('ticker not found');
            }
        });
    })(jQuery);
    </script>
<ul id="rt-js-news" class="js-hidden">
<li class="news-item"><a href="https://www.underhoodservice.com/watch-now-led-lighting/">LED Lighting &#8211; What Are the OES Doing and What Can You Do?</a></li>
<li class="news-item"><a href="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/">Using J2534 Programming Devices</a></li>
<li class="news-item"><a href="https://www.underhoodservice.com/the-changing-vehicle-ownership-cycle/">The Changing Vehicle Ownership Cycle</a></li>
<li class="news-item"><a href="https://www.underhoodservice.com/gfs-lincoln-tech-partner-for-collision-repair-tech-training/">GFS, Lincoln Tech Partner For Collision Repair Training</a></li>
<li class="news-item"><a href="https://www.underhoodservice.com/mobile-tech-connects-students-with-companies-at-skillsusa/">Mobile Tech Connects Students With Companies at SkillsUSA</a></li>
<li class="news-item"><a href="https://www.underhoodservice.com/repairpal-keysavvy-partner-to-provide-repair-services/">Repairpal, Keysavvy Partner To Provide Repair Services</a></li>
</ul>
<style>
    .ticker-title { background-color: #F8ED33; }
    .ticker-title .boltu-right { border-top: 8px solid #F8ED33; }
    </style>
</div>
</div>
<div id="mvp-main-body-wrap" class="left relative">

<div class="mvp-main-body-grid relative">
<div class="mvp-main-body-cont relative"> <div class="mvp-auto-post-grid">
<div class="mvp-alp-side">
<div class="mvp-alp-side-in">
<div class="alp-left-side-content">
<div class="alp-content-wrap">
<div class="alp-category-wrap">
<a href="https://www.underhoodservice.com/category/diagnostic/">
<img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Diagnostics-Category-Image.png" class="alp-category-icon">
</a>
</div>
 <div class="alp-sidebar-header-wrap">
<div class="alp-sidebar-header-left-side">
<broadstreet-zone zone-id="76779"></broadstreet-zone>
</div>
<div class="alp-related-posts-wrapper">
<div class="alp-related-posts">
<div class="alp-related-post post-188842 current" data-id="188842" data-document-title="">
<div class="post-details">
<p class="post-meta">
<div class="mvp-author-info-wrap">
<div class="mvp-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="mvp-author-name vcard fn author" itemprop="name"><a href="https://www.underhoodservice.com/author/dseyfer/">Donny Seyfer</a></span>
</div>
<div class="mvp-post-date-wrap">
<p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-06-24">Jun 24, 2022</time></span>
<meta itemprop="dateModified" content="2022-06-24" />
</div>
</div>
</p>
<a class="post-title" href="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/">Using J2534 Programming Devices</a>
</div>
<div class="mvp-alp-soc-wrap">
<ul class="mvp-alp-soc-list">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/&amp;t=Using J2534 Programming Devices', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-alp-soc-fb"><span class="fab fa-facebook"></span></li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Using J2534 Programming Devices &amp;url=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-alp-soc-twit"><span class="fab fa-twitter"></span></li>
</a>
<a href="#" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/'); return false;" title="Share on LinkedIn">
<li class="mvp-alp-soc-link"><span class="fab fa-linkedin-in"></span></li>
</a>

<a href="/cdn-cgi/l/email-protection#49763a3c2b232c2a3d741c3a20272e69037b7c7a7d69193b262e3b28242420272e690d2c3f202a2c3a6f282439720b060d107400692f263c272d693d21203a69283b3d202a252c6920273d2c3b2c3a3d20272e6928272d693d21263c2e213d69262f693a21283b20272e69203d693e203d216930263c67690a212c2a2269203d69263c3d7369213d3d393a7366663e3e3e673c272d2c3b2126262d3a2c3b3f202a2c672a2624663c3a20272e64237b7c7a7d64393b262e3b28242420272e642d2c3f202a2c3a6c2c2f6c2b2f6c2b2a66">
<li class="mvp-alp-soc-com"><span class="fas fa-envelope"></span></li>
</a>
</ul>
</div>
</div>
<div class="alp-advert">
</div>
<div class="alp-related-post post-188850 " data-id="188850" data-document-title="">
<div class="post-details">
<p class="post-meta">
<div class="mvp-author-info-wrap">
<div class="mvp-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="mvp-author-name vcard fn author" itemprop="name"><a href="https://www.underhoodservice.com/author/amarkelbabcox-com/">Andrew Markel</a></span>
</div>
<div class="mvp-post-date-wrap">
<p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-06-24">Jun 21, 2022</time></span>
<meta itemprop="dateModified" content="2022-06-24" />
</div>
</div>
</p>
<a class="post-title" href="https://www.underhoodservice.com/tpms-sensor-signals/">TPMS Sensor Signals</a>
</div>
<div class="mvp-alp-soc-wrap">
<ul class="mvp-alp-soc-list">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.underhoodservice.com/tpms-sensor-signals/&amp;t=TPMS Sensor Signals', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-alp-soc-fb"><span class="fab fa-facebook"></span></li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=TPMS Sensor Signals &amp;url=https://www.underhoodservice.com/tpms-sensor-signals/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-alp-soc-twit"><span class="fab fa-twitter"></span></li>
</a>
<a href="#" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.underhoodservice.com/tpms-sensor-signals/'); return false;" title="Share on LinkedIn">
<li class="mvp-alp-soc-link"><span class="fab fa-linkedin-in"></span></li>
</a>

<a href="/cdn-cgi/l/email-protection#46793533242c2325327b12160b156615232835293466152f2128272a3560272b367d0409021f7b0f66202933282266322e2f35662734322f252a23662f283223342335322f28216627282266322e2933212e3266292066352e27342f2821662f3266312f322e663f29336866052e23252d662f32662933327c662e323236357c69693131316833282223342e292922352334302f25236825292b6932362b356b3523283529346b352f2128272a3569">
<li class="mvp-alp-soc-com"><span class="fas fa-envelope"></span></li>
</a>
</ul>
</div>
</div>
<div class="alp-related-post post-188498 " data-id="188498" data-document-title="">
<div class="post-details">
<p class="post-meta">
<div class="mvp-author-info-wrap">
<div class="mvp-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="mvp-author-name vcard fn author" itemprop="name"><a href="https://www.underhoodservice.com/author/amarkelbabcox-com/">Andrew Markel</a></span>
</div>
<div class="mvp-post-date-wrap">
<p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-06-24">Jun 2, 2022</time></span>
<meta itemprop="dateModified" content="2022-06-24" />
</div>
</div>
</p>
<a class="post-title" href="https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/">Improve Diagnostic Skills By Listening Better</a>
</div>
<div class="mvp-alp-soc-wrap">
<ul class="mvp-alp-soc-list">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/&amp;t=Improve Diagnostic Skills By Listening Better', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-alp-soc-fb"><span class="fab fa-facebook"></span></li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Improve Diagnostic Skills By Listening Better &amp;url=https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-alp-soc-twit"><span class="fab fa-twitter"></span></li>
</a>
<a href="#" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.underhoodservice.com/improve-diagnostic-skills-by-listening-better/'); return false;" title="Share on LinkedIn">
<li class="mvp-alp-soc-link"><span class="fab fa-linkedin-in"></span></li>
</a>

<a href="/cdn-cgi/l/email-protection#97a8e4e2f5fdf2f4e3aadefae7e5f8e1f2b7d3fef6f0f9f8e4e3fef4b7c4fcfefbfbe4b7d5eeb7dbfee4e3f2f9fef9f0b7d5f2e3e3f2e5b1f6fae7acd5d8d3ceaadeb7f1f8e2f9f3b7e3fffee4b7f6e5e3fef4fbf2b7fef9e3f2e5f2e4e3fef9f0b7f6f9f3b7e3fff8e2f0ffe3b7f8f1b7e4fff6e5fef9f0b7fee3b7e0fee3ffb7eef8e2b9b7d4fff2f4fcb7fee3b7f8e2e3adb7ffe3e3e7e4adb8b8e0e0e0b9e2f9f3f2e5fff8f8f3e4f2e5e1fef4f2b9f4f8fab8fefae7e5f8e1f2baf3fef6f0f9f8e4e3fef4bae4fcfefbfbe4baf5eebafbfee4e3f2f9fef9f0baf5f2e3e3f2e5b8">
<li class="mvp-alp-soc-com"><span class="fas fa-envelope"></span></li>
</a>
</ul>
</div>
</div>
<div class="alp-related-post post-188476 " data-id="188476" data-document-title="">
<div class="post-details">
<p class="post-meta">
<div class="mvp-author-info-wrap">
<div class="mvp-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="mvp-author-name vcard fn author" itemprop="name"><a href="https://www.underhoodservice.com/author/amarkelbabcox-com/">Andrew Markel</a></span>
</div>
<div class="mvp-post-date-wrap">
<p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-06-24">Apr 8, 2022</time></span>
<meta itemprop="dateModified" content="2022-06-24" />
</div>
</div>
</p>
<a class="post-title" href="https://www.underhoodservice.com/air-management-for-the-fsi-v6-and-v8-engines-2/">Air Management For The FSI V6 And V8 Engines</a>
</div>
<div class="mvp-alp-soc-wrap">
<ul class="mvp-alp-soc-list">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.underhoodservice.com/air-management-for-the-fsi-v6-and-v8-engines-2/&amp;t=Air Management For The FSI V6 And V8 Engines', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-alp-soc-fb"><span class="fab fa-facebook"></span></li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Air Management For The FSI V6 And V8 Engines &amp;url=https://www.underhoodservice.com/air-management-for-the-fsi-v6-and-v8-engines-2/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-alp-soc-twit"><span class="fab fa-twitter"></span></li>
</a>
<a href="#" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.underhoodservice.com/air-management-for-the-fsi-v6-and-v8-engines-2/'); return false;" title="Share on LinkedIn">
<li class="mvp-alp-soc-link"><span class="fab fa-linkedin-in"></span></li>
</a>

<a href="/cdn-cgi/l/email-protection#91aee2e4f3fbf4f2e5acd0f8e3b1dcf0fff0f6f4fcf4ffe5b1d7fee3b1c5f9f4b1d7c2d8b1c7a7b1d0fff5b1c7a9b1d4fff6f8fff4e2b7f0fce1aad3ded5c8acd8b1f7fee4fff5b1e5f9f8e2b1f0e3e5f8f2fdf4b1f8ffe5f4e3f4e2e5f8fff6b1f0fff5b1e5f9fee4f6f9e5b1fef7b1e2f9f0e3f8fff6b1f8e5b1e6f8e5f9b1e8fee4bfb1d2f9f4f2fab1f8e5b1fee4e5abb1f9e5e5e1e2abbebee6e6e6bfe4fff5f4e3f9fefef5e2f4e3e7f8f2f4bff2fefcbef0f8e3bcfcf0fff0f6f4fcf4ffe5bcf7fee3bce5f9f4bcf7e2f8bce7a7bcf0fff5bce7a9bcf4fff6f8fff4e2bca3be">
<li class="mvp-alp-soc-com"><span class="fas fa-envelope"></span></li>
</a>
</ul>
</div>
</div>
</div>
</div>
</div>
<div class="alp-post-sidebar">
<section id="custom_html-3" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><hr width="80%"></div></section><div class="hr"></div><section id="bcx_ad_widget-13" class="mvp-side-widget bcx_ad_widget"> <div class="bcx-ad-wrap">
<div class="bcx-ad-title">
Advertisement </div>
<div class="bcx-ad-content billboard">
<broadstreet-zone zone-id="92590"></broadstreet-zone>
</div>
</div>
</section><div class="hr"></div> <section id="garage_studio_widget-3" class="mvp-side-widget garage_studio_widget"> <div class="bcx-center">
<div class="garage-studio-video-wrap">
<div class="gs-video-wrap">
<div id="garage-studio-widget-video-188819" class="garage-studio-widget-video-188819" data-video_id="xyZtEzz5">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="https://cdn.jwplayer.com/libraries/voYL6oz2.js"></script>
<script type="text/javascript">
			                jwplayer('garage-studio-widget-video-188819').setup({
			                    file: 'https://content.jwplatform.com/videos/xyZtEzz5-720.mp4',
			                    image: 'https://content.jwplatform.com/thumbs/xyZtEzz5-720.jpg',
			                    width: '100%',
			                    aspectratio: '16:9'
			                });
			            </script>
</div>

</div>
</div>
</div>
</section><div class="hr"></div><section id="media_image-5" class="mvp-side-widget widget_media_image"><a href="/tag/acdelcotv"><img width="600" height="200" src="https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200.jpg" class="image wp-image-187622  attachment-full size-full" alt="ACDelco TV Series Banner" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200.jpg 600w, https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200-300x100.jpg 300w, https://s19539.pcdn.co/wp-content/uploads/2021/10/ACDelcoTV600x200-598x200.jpg 598w" sizes="(max-width: 600px) 100vw, 600px" /></a></section><div class="hr"></div> <section id="garage_studio_widget-5" class="mvp-side-widget garage_studio_widget"> <div class="bcx-center">
<div class="garage-studio-video-wrap">
<div class="gs-video-wrap">
<div id="garage-studio-widget-video-187495" class="garage-studio-widget-video-187495" data-video_id="VhBSAAdc">
<script src="https://cdn.jwplayer.com/libraries/NJFp4RYM.js"></script>
<script type="text/javascript">
			                jwplayer('garage-studio-widget-video-187495').setup({
			                    file: 'https://content.jwplatform.com/videos/VhBSAAdc-720.mp4',
			                    image: 'https://content.jwplatform.com/thumbs/VhBSAAdc-720.jpg',
			                    width: '100%',
			                    aspectratio: '16:9'
			                });
			            </script>
</div>

<h5 class="text-left"><a href="https://www.underhoodservice.com/video-acdelco-spark-plugs/">Selecting The Correct ACDelco Spark Plug (VIDEO)</a></h5>
</div>
<div class="garage-studio-other-videos">
<div class="media item-shadow-gray mb-30 boxed">
<div class="image-left">
<a class="img-opacity-hover" href="https://www.underhoodservice.com/video-acdelco-starter-and-alternators/">
<img width="150" height="150" src="https://s19539.pcdn.co/wp-content/uploads/2021/10/acdelco-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" loading="lazy" srcset="https://s19539.pcdn.co/wp-content/uploads/2021/10/acdelco-150x150.jpg 150w, https://s19539.pcdn.co/wp-content/uploads/2021/10/acdelco-80x80.jpg 80w" sizes="(max-width: 150px) 100vw, 150px" /> </a>
</div>
<div class="media-body text-left">
<h3 class="title-medium-dark size-md mb-none">
<a href="https://www.underhoodservice.com/video-acdelco-starter-and-alternators/">VIDEO: ACDelco Starter And Alternators</a>
</h3>
<p class="excerpt-medium-dark size-md mb-none">High underhood temps, increased power demands and vibration can damage alternators or starters. Sponsored by ACDelco.</p>
</div>
</div>
<div class="media item-shadow-gray mb-30 boxed">
<div class="image-left">
<a class="img-opacity-hover" href="https://www.underhoodservice.com/video-replacement-long-block-engines/">
<img width="150" height="150" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/replacementacdelco-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" loading="lazy" srcset="https://s19539.pcdn.co/wp-content/uploads/2021/09/replacementacdelco-150x150.jpg 150w, https://s19539.pcdn.co/wp-content/uploads/2021/09/replacementacdelco-80x80.jpg 80w" sizes="(max-width: 150px) 100vw, 150px" /> </a>
</div>
<div class="media-body text-left">
<h3 class="title-medium-dark size-md mb-none">
<a href="https://www.underhoodservice.com/video-replacement-long-block-engines/">VIDEO: Replacement Long Block Engines</a>
</h3>
<p class="excerpt-medium-dark size-md mb-none">Don’t settle for “almost” - it matters where the engine is manufactured or remanufactured. Sponsored by ACDelco.</p>
</div>
</div>
</div>
</div>
</div>
</section><div class="hr"></div> <div class="bcx-video-widget-wrap">
<div class="bcx-video-widget-featured">
<img class="bcx-video-widget-image" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/Video-Category-Image.png" alt="Featured Widget Image">
<h3 class="bcx-video-widget-label">Featured Video of the Week</h3>
<div class="bcx-video-featured hover-show-play-btn">
<div class="img-overlay-70">
<a href="https://www.underhoodservice.com/video-brake-pads-deconstructed/" class="img-opacity-hover img-overlay-70">
<img width="100%" src="https://s19539.pcdn.co/wp-content/uploads/2021/09/2P8_5361.jpg" class="img-fluid mb-10 width-100 wp-post-image" alt="VIDEO: Brake Pads Deconstructed">
</a>
<div class="video-icon">
<a href="https://www.underhoodservice.com/video-brake-pads-deconstructed/">
<img class="no-lazyload" src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-PlayButton.png" alt="play">
</a>
</div>
</div>
<div class="video-content">
<h3 class="title-medium-dark">
<a href="https://www.underhoodservice.com/video-brake-pads-deconstructed/">VIDEO: Brake Pads Deconstructed</a>
</h3>
<p class="video-excerpt">Brake pads are thoroughly developed to produce the best result. This video is sponsored by ZF Aftermarket.</p>
</div>
</div>
</div>
<div class="bcx-video-widget-side">
<div class="default-slider owl-item active ">
<div class="rtin-item">
<div class="hover-show-play-btn">
<div class="img-overlay-70">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/" class="img-opacity-hover img-overlay-70">
<img width="400" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/Screen-Shot-2022-06-20-at-3.11.38-PM.png" class="img-fluid mb-10 width-100 wp-post-image" alt="Cooling System: Hose Inspection and Replacement">
</a>
<a href="https://www.underhoodservice.com/category/original-video/">
<span class="el-rt-cat style_2">Video</span>
</a>
<div class="video-icon">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/">
<img class="no-lazyload" src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-PlayButton.png" alt="play">
</a>
</div>
</div>
<div class="video-content">
<h3 class="title-medium-dark">
<a href="https://www.underhoodservice.com/cooling-system-hose-inspection-and-replacement/">Cooling System: Hose Inspection and Replacement</a>
</h3>
</div>
</div>
</div>
</div>
<div class="default-slider owl-item active ">
<div class="rtin-item">
<div class="hover-show-play-btn">
<div class="img-overlay-70">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/" class="img-opacity-hover img-overlay-70">
 <img width="400" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/lubegard.jpg" class="img-fluid mb-10 width-100 wp-post-image" alt="GM Eight Speed Torque Converter Shudder Solution (VIDEO)">
</a>
<a href="https://www.underhoodservice.com/category/original-video/">
<span class="el-rt-cat style_2">Video</span>
</a>
<div class="video-icon">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">
<img class="no-lazyload" src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/CD-PlayButton.png" alt="play">
</a>
</div>
</div>
<div class="video-content">
<h3 class="title-medium-dark">
<a href="https://www.underhoodservice.com/gm-eight-speed-torque-converter-shudder-solution-video/">GM Eight Speed Torque Converter Shudder Solution (VIDEO)</a>
</h3>
</div>
</div>
</div>
</div>
</div>
</div>
<section id="custom_html-4" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><hr width="80%"></div></section><div class="hr"></div> <section id="latest_podcast_widget-3" class="mvp-side-widget latest_podcast_widget"> <div class="bcx-latest-podcast">
</div>
</section><div class="hr"></div> <section id="current_digital_issue_widget-3" class="mvp-side-widget current_digital_issue_widget"> <div class="bcx-current-issue text-center">
<h2 class="bcx-current-issue-title">Current Digital Issue</h2>
<div class="row">
<div class="col-sm-12">
<a href="https://digital.shopownermag.com/html5/reader/production/default.aspx?pubname=&pubid=9fbe8b6e-6571-4310-985d-a5b79a898007" target="_blank">
<img src="https://s19539.pcdn.co/wp-content/uploads/2022/06/so.June_.22.CoverSO-219x300.jpg" alt="June 2022">
</a>
<p class="bcx-current-issue-label">Digital Edition</p>
</div>
</div>
<p class="bcx-current-issue-text">
<a href="https://www.underhoodservice.com/magazine/">Click here</a> to view past issues. </p>
<a target="_blank" class="clear-btn subscribe" href="/subscribe">Subscribe</a>
</div>
</section><div class="hr"></div><section id="bcx_recent_single_widget-15" class="mvp-side-widget bcx_recent_single_widget"> <div class="bcx-container bcx-widget relative">
<h4 class="bcx-recent-label">Webinars</h4>
<ul class="bcx-recent-list">
<li><a href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite" target="_blank">Upcoming Webinar</a></li> <li><a href="https://webinars.on24.com/babcox/repairshopHQ?partnerref=UHSwebsite" target="_blank">Most Recent Webinar</a></li> <li><a href="/webinars/">View More Webinars</a></li>
</ul>
</div>
</section><div class="hr"></div><section id="sponsored_content_widget-4" class="mvp-side-widget sponsored_content_widget"> <div class="bcx-container bcx-widget relative sponsored-content-widget">
<h4 class="bcx-recent-label">Sponsored Content</h4>
<div class="sponsored-content-widget-inner">
<div>
<a href="https://www.underhoodservice.com/protect-your-fuel-tank-and-pump-with-delphi-technologies/">
<img width="740" height="354" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/Picture1.jpg" class="sponsored-content-img wp-post-image" alt="" loading="lazy" srcset="https://s19539.pcdn.co/wp-content/uploads/2022/06/Picture1.jpg 936w, https://s19539.pcdn.co/wp-content/uploads/2022/06/Picture1-300x144.jpg 300w, https://s19539.pcdn.co/wp-content/uploads/2022/06/Picture1-768x368.jpg 768w" sizes="(max-width: 740px) 100vw, 740px" /> </a>
</div>
<h3 class="sponsored-content-widget-title"><a href="https://www.underhoodservice.com/protect-your-fuel-tank-and-pump-with-delphi-technologies/">Protect Your Fuel Tank and Pump With Delphi Technologies </a></h3>
</div>
</div>
</section><div class="hr"></div> <div class="bcx-subscribe" style="background-color: #1863af;">
<span style="color: #ffffff;">Newsletter</span>
<p style="color: #ffffff;">Get the latest news, insights, and more delivered directly to you inbox.</p>
<div class="bcx-subscribe-btn-container">
<a href="/subscribe" style="background-color: #000000; color: #ffffff;" rel="noopener noreferrer" target="_blank">
Subscribe </a>
</div>
</div>
</div>
</div>
</div>
<div class="alp-left-side-hide">
<span class="alp-caret-left"></span>
<span class="alp-left-side-label">Close Sidebar Panel</span>
<span class="alp-left-side-label-closed">Open Sidebar Panel</span>
<span class="alp-caret-left"></span>
</div> </div>
</div>
<div class="mvp-auto-post-main ">
<article id="post-188842" class="post-188842 post type-post status-publish format-standard has-post-thumbnail hentry category-diagnostic tag-diagnostic-tools tag-flash-reprogramming tag-sae-j2534 covercategory-june-2022" class="mvp-post-wrap" itemscope itemtype="http://schema.org/NewsArticle">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/" />
<div class="mvp-post-img-wrap left relative">
<div class="mvp-post-img left relative" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1400" height="700" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg 1400w, https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-300x150.jpg 300w, https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-1024x512.jpg 1024w, https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-768x384.jpg 768w, https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534-1200x600.jpg 1200w" sizes="(max-width: 1400px) 100vw, 1400px" /> <meta itemprop="url" content="https://s19539.pcdn.co/wp-content/uploads/2022/06/SAE-J2534.jpg">
<meta itemprop="width" content="1400">
<meta itemprop="height" content="700">
</div>
<div class="mvp-post-img-text-wrap temp5">
<div class="mvp-post-img-text-main">
<h3 class="mvp-post-cat">
<a class="mvp-post-cat-link" href="https://www.underhoodservice.com/category/diagnostic/"><span class="mvp-post-cat">Diagnostics</span></a>
</h3>
<h1 class="mvp-post-title left entry-title" itemprop="headline">Using J2534 Programming Devices</h1>
</div>
</div>
</div>
<div class="bcx-featured-template">
<span class="mvp-post-excerpt"><p>How much money are you losing by not programming?</p>
</span>
<div class="bcx-ad-wrap">
<div class="bcx-ad-title">Advertisement</div>
<div class="bcx-ad-content leaderboard">
<broadstreet-zone zone-id="76780"></broadstreet-zone>
</div>
</div>
<div class="bcx-author-container">
<div class="mvp-post-info-wrap mvp-post-info-wrap2">
<div class="mvp-author-thumb">
<img src="https://s19539.pcdn.co/wp-content/uploads/2016/01/Screen-Shot-2016-01-18-at-1.34.21-PM-150x150.png" width="46" height="46" alt="Donny Seyfer" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" /> </div>
<div class="mvp-author-info-wrap">
<div class="mvp-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="mvp-author-name vcard fn author" itemprop="name"><a href="https://www.underhoodservice.com/author/dseyfer/" title="Posts by Donny Seyfer" rel="author">Donny Seyfer</a></span>
</div>
<div class="mvp-post-date-wrap">
<p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-06-24">Jun 24, 2022</time></span>
<meta itemprop="dateModified" content="2022-06-24" />
</div>
</div>
</div>
</div>
</div>
<div class="mvp-post-main left relative">
<div class="mvp-post-body left relative">
<div class="mvp-post-content left relative">
<div class="mvp-content-wrap relative">
<div class="mvp-content-main read-more left relative">
<div class="mvp-content-inner">
<p>For many of us, J2534 is a nebulous term or one that brings fears of “bricked” modules and hours of frustration to perform what should be a simple firmware update on a vehicle’s module.</div><div class="mvp-content-read-more-text">Click Here to Read More</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur row"><div class="col-12 text-center"><div id="omeda-inline-subscribe" class="omeda-inline-subscribe"></div></div></div><div class="mvp-content-inner mvp-blur">
<p>The ultimate goal of J2534 for 2018 model year and, in some cases, much earlier vehicles is for shops to be able to run OEM and aftermarket scan tool software and programming applications to include vehicle security over a common standardized Vehicle Communication Interface (VCI).&nbsp;</p>
<p>To help relieve your trepidation with J2534, let’s first start at a high level and talk about what it can do. Our industry has lots of gurus on this topic and, in my experience, they assume a high level of understanding on the part of technicians when they talk about the topic.</p>
<p>The name itself is an SAE (Society of Automotive Engineers) number assigned to a project, protocol or standard. In reality, J2534 is all of the above. It has five different iterations intended to perform different functions when applied to an OBDII-equipped vehicle. That is as deep as I am going to go into SAE for this article.</p>
<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://s19539.pcdn.co/wp-content/uploads/2022/06/J2534-fro-2018-vehicle.jpg"><img loading="lazy" width="700" height="500" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/J2534-fro-2018-vehicle.jpg" alt="" class="wp-image-188844" srcset="https://s19539.pcdn.co/wp-content/uploads/2022/06/J2534-fro-2018-vehicle.jpg 700w, https://s19539.pcdn.co/wp-content/uploads/2022/06/J2534-fro-2018-vehicle-300x214.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" /></a></figure></div>
<p>The original intended use for J2534 protocols was to create a standardized way to update software (firmware) on the powertrain control module on OBDII vehicles. The problem back then, and still present in your bays today, is that the vehicle development cycle was already in motion when J2534-1 was moving from infancy to usefulness. This means that you have some brands that could not support this type of programming well into the early 2000s. There are workarounds for that group of vehicles, but let’s say they are not very user friendly. In those situations, a factory scan tool is pretty much the only solution.&nbsp;</p>
<p>As time passed, J2534 evolved to include additional capabilities and incorporate some ISO (International Standards Organization) protocols and techniques. This effectively brought more Asian and European cars to the table. During this time, discussions about a standard interface for diagnostics were occurring throughout the industry, and J2534 was chosen as the basis for the “universal” VCI.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content billboard"><broadstreet-zone zone-id="76781"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>Automakers have agreed through a Memorandum of Understanding (MOU) to make their diagnostic and reprogramming capabilities available over the J2534 platform.&nbsp;</p>
<p>So, is it truly universal? The short answer; not yet. This is a big topic, so I am going to give you a fairly broad answer from my experience working with toolmakers, technicians and automakers at NASTF. Due to the requirements of making a J2534 tool work as a complete diagnostic solution, there has been impressive collaboration between all the parties.</p>
<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://s19539.pcdn.co/wp-content/uploads/2022/06/National-Automotive-Sevice-Task-Force.jpg"><img loading="lazy" width="700" height="500" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/National-Automotive-Sevice-Task-Force.jpg" alt="" class="wp-image-188845" srcset="https://s19539.pcdn.co/wp-content/uploads/2022/06/National-Automotive-Sevice-Task-Force.jpg 700w, https://s19539.pcdn.co/wp-content/uploads/2022/06/National-Automotive-Sevice-Task-Force-300x214.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" /></a></figure></div>
<p>The reason that we are not fully universal lies in all the variations of hardware and some legacy protocols that exist on vehicles. With that said, the requirement was for 2018 and beyond models to be fully compliant. Some automakers, for example, Ford, Hyundai and Kia, had such a big change to make that they decided to create a completely new tool to meet the criteria. Others have been working on J2534 for some time and are backward compatible for many years of vehicles —Toyota, GM, BMW, Jaguar/Land Rover, to name a few.&nbsp;</p>
<p>So, depending on what you are tooling up for, a complete solution may be available for the VCI portion. This leads me to the last issue we have not talked about, and that is the PC. It would be ideal to be able to run one PC and have every OEM vehicle you work on to be set up on it. There are problems with this from both an IT and pragmatic standpoint.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>First, the IT issue. Familiar companies, for example Bosch and Snap-on, develop many of these applications. GM and Ford use a nearly identical Dealer VCI in their tools and these are basically J-boxes, but there may be specific software components that are not compatible on the same computer, which can make the software inoperable. You can have a pair of VCIs that put their software in the same location on your computer, but are not the same versions and you run into a problem. This means that, for most shops, you would want to run several laptops with more than one Windows partition on the hard drive to facilitate different scan tool software.&nbsp;</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>There are pragmatic business reasons to support this. First, you can buy refurb Windows machines out there for under $400 with adequate drive space, memory and an i5 processor. With a little planning, you can spread your software out between machines and reduce the bottleneck that could occur when every tech wants the same machine. You might be thinking that you would want to make more than one install of the same tool on multiple machines. For a number of reasons, this will be more of a hassle than you would want to deal with.&nbsp;</p>
<h3><strong>HOW DO I GET THIS TO WORK?</strong></h3>
<p>There are a couple of terms you need to familiarize yourself with because, if you have not already made the leap, our job includes IT these days.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>Take the word Firmware, for example. This is tricky because technically the “reflash file” you install is firmware, but, generally, when the term is used in a 2534 setup, it is talking about the software version that is on the VCI device itself. To make all of these things talk to one another, you have to match up the OE software, the PC operating system, the plug-ins (Java, web browsers and a few OE specific plug ins) and the VCI firmware. Outdated or incompatible versions can put the brakes on the whole communication.</p>
<div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://s19539.pcdn.co/wp-content/uploads/2022/06/Automotive-Diagnostic-equipement.jpg"><img loading="lazy" width="700" height="500" src="https://s19539.pcdn.co/wp-content/uploads/2022/06/Automotive-Diagnostic-equipement.jpg" alt="" class="wp-image-188846" srcset="https://s19539.pcdn.co/wp-content/uploads/2022/06/Automotive-Diagnostic-equipement.jpg 700w, https://s19539.pcdn.co/wp-content/uploads/2022/06/Automotive-Diagnostic-equipement-300x214.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" /></a></figure></div>
<p>Sounds hard? It’s not. Developers and automakers say to always keep everything updated to the latest version unless a message warns you otherwise. This makes taking 15 seconds to scan the help topics or news section of the website very important. Most of the time the automaker site will have warnings posted where you have to work to miss them.&nbsp;</p>
<p>After you do any kind of change, save yourself hours of potential headaches by logging out of the OEM site and completely restarting everything in the prescribed order: PC, connect the 2534 VCI, start the software, then turn on the car, for example. Yes, the car will often need to be shut off and turned back on several times during the operation. Generally start with “on” when you are establishing communications. Experienced re-programmers call this the “key dance,” although it is becoming the push-button dance.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>If you have all of the software updated and ready to go, you may still have a couple of things to check. Make sure you have internet access working — open a browser and hit a website. The next thing you must do is to make sure your particular J2534 box is selected within the automaker software. Some automaker applications, like GM’s, will lead you through it. Toyota, for example, stores your settings in its Techstream application, so you will need to go into settings and choose your VCI the first time you use it. In both cases, the automakers have an excellent graphic help guide to get you started on their website.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>The first time is always the worst time. You may have to enter a license, as in the aforementioned Techstream, or you may have to install various drivers (another one of those terms) or updates to them. I figure it takes me about 30 minutes to set up a J2534 package for most automakers. It will go much better if you read all of their documentation prior to attempting it.&nbsp;</p>
<p>One of the things mentioned were licenses. When you download the application for reflashing, most of the time the actual interface software is a free download, but there is a subscription to the website to get the actual information. You are asking for trouble when you attempt to move the VCI around between multiple machines to service the same brand. Most automakers take similar approaches to their software, as companies like Microsoft or Adobe. By looking at IP addresses, if they suspect that you are sharing your subscription — by the number of different machines accessing the same account or geographical use data — they will shut down your machine and you will have some explaining to do to get it turned back on.&nbsp;</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>It seems that there are as many different approaches to reprogramming as there are automakers. You can find information on how these subscriptions work at www.nastf.org. You will also find links to all the OEM sites and information on how their programming works. Most of the European brands will take more time to configure. Up to the early 2000s, many Asian brands could not be updated by J2534 methods, or at all. Almost every manufacturer has a car line or model with some idiosyncrasy to software updates. These are generally the “collaborative” models, like the VW Routan, which was actually built by Chrysler.</div><div class="bcx-ad-wrap mvp-blur"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content rectangle"><broadstreet-zone zone-id="76779"></broadstreet-zone></div></div><div class="mvp-content-inner mvp-blur">
<p>I cannot stress enough how important it is to read the TSBs and procedures for the vehicle in advance of starting a repair. Very few reflash operations will result in a “bricked module” that you have to pay for should something go wrong, but the process can go from five minutes of turning the key off and on while you hit enter on the computer, to a very time-consuming process.</p>
<p>I may not have convinced you to begin programming, but I will ask this: If now is not the time, when will it be? There are mountains of repair procedures that cannot be completed without a flash or recode. If you wait until it is a part of every operation, the big question, “When will I make money with this?,” will be replaced with, “How much money am I losing by not doing this? </p>
</p> </div>
</div>
<div class="bcx-ad-wrap"><div class="bcx-ad-title">Advertisement</div><div class="bcx-ad-content leaderboard"><broadstreet-zone zone-id="76780"></broadstreet-zone></div></div>
<div class="mvp-alp-soc-reg left relative">
<div class="mvp-alp-soc-wrap">
<ul class="mvp-alp-soc-list">
<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/&amp;t=Using J2534 Programming Devices', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="mvp-alp-soc-fb"><span class="fab fa-facebook"></span></li>
</a>
<a href="#" onclick="window.open('http://twitter.com/share?text=Using J2534 Programming Devices &amp;url=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="mvp-alp-soc-twit"><span class="fab fa-twitter"></span></li>
</a>
<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.underhoodservice.com/using-j2534-programming-devices%ef%bf%bc/&amp;media=https://www.underhoodservice.com/wp-content/uploads/2022/06/SAE-J2534-1000x563.jpg&amp;description=Using J2534 Programming Devices', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="mvp-alp-soc-pin"><span class="fab fa-pinterest-p"></span></li>
</a>
<a href="/cdn-cgi/l/email-protection#f1ce8284939b949285cca482989f96d1bbc3c4c2c5d1a1839e9683909c9c989f96d1b5948798929482d7909c81cab3beb5a8ccb8d1979e849f95d185999882d190838598929d94d1989f859483948285989f96d1909f95d185999e84969985d19e97d182999083989f96d19885d186988599d1889e84dfd1b29994929ad19885d19e8485cbd19985858182cbdede868686df849f959483999e9e9582948387989294df929e9cde8482989f96dc9bc3c4c2c5dc81839e9683909c9c989f96dc95948798929482d49497d49397d49392de">
<li class="mvp-alp-soc-com"><span class="fas fa-envelope"></span></li>
</a>
</ul>
</div>
</div>
<div class="mvp-post-bot-wrap left relative">
<div class="mvp-post-bot">
<div class="mvp-post-tags left relative">
<span class="mvp-post-tags-header">In this article:</span><span itemprop="keywords"><a href="https://www.underhoodservice.com/tag/diagnostic-tools/" rel="tag">diagnostic tools</a>, <a href="https://www.underhoodservice.com/tag/flash-reprogramming/" rel="tag">FLASH Reprogramming</a>, <a href="https://www.underhoodservice.com/tag/sae-j2534/" rel="tag">SAE J2534</a></span>
</div>
<div class="posts-nav-link">
</div>
<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png" />
<meta itemprop="url" content="https://s19539.pcdn.co/wp-content/uploads/2021/09/UHS-final-logo.png">
</div>
<meta itemprop="name" content="UnderhoodService">
</div>
<div id="mvp-comments-button" class="left relative mvp-com-click mvp-com-click-188842 mvp-com-but-188842">
<span class="mvp-comment-but-text"><i class="fas fa-comment"></i> <span class="dsq-postid" data-dsqidentifier="188842 https://www.underhoodservice.com/?p=188842">Click to comment</span></span>
</div>
<div id="disqus_thread"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  	  $(".mvp-com-click-188842").on("click", function(){
  	    $(".mvp-com-click-id-188842").show();
	    $(".disqus-thread-188842").show();
  	    $(".mvp-com-but-188842").hide();
	  });
	});
    </script> <div class="bcx-suggested-container">
<div class="bcx-suggested">
<div class="bcx-suggested-posts">
<div class="bcx-suggested-post" data-suggested-post="188227">
<p><a href="https://www.underhoodservice.com/exhaust-gas-recirculation-operation-and-diagnostics/"><span>Diagnostics:&nbsp;</span>Exhaust Gas Recirculation Operation and Diagnostics</a></p>
</div>
<div class="bcx-suggested-post" data-suggested-post="188275">
<p><a href="https://www.underhoodservice.com/ford-illuminated-malfunction-indicator-lamp/"><span>Diagnostics:&nbsp;</span>Ford Illuminated Malfunction Indicator Lamp</a></p>
</div>
<div class="bcx-suggested-post" data-suggested-post="188276">
<p><a href="https://www.underhoodservice.com/rough-running-gm-vehicle/"><span>Diagnostics:&nbsp;</span>Rough Running GM Vehicle</a></p>
</div>
<div class="bcx-suggested-post" data-suggested-post="188273">
<p><a href="https://www.underhoodservice.com/lost-or-stolen-key-gm-vehicles/"><span>Diagnostics:&nbsp;</span>Lost Or Stolen Key GM Vehicles</a></p>
</div>
</div>
<div class="bcx-suggested-ad">
<div class="bcx-ad-wrap">
<div class="bcx-ad-title">Advertisement</div>
<div class="bcx-ad-content rectangle">
<broadstreet-zone zone-id="76779"></broadstreet-zone>
</div>
</div>
</div>
</div>
</div>
</article>
</div>
</div> </div>
<footer id="mvp-foot-wrap">
<div class="mvp-foot-top left relative">
<div class="mvp-foot-marg">
<div class="container">
<div class="row">
<div class="col-md-3">
<div class="footer-widgets">
<h4 class="mvp-widget-footer-title"><span class="mvp-widget-footer-title">Subscribe</span></h4>
<div class="menu-subscribe-container"><ul id="menu-subscribe" class="menu"><li id="menu-item-153390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153390"><a target="_blank" rel="noopener" href="/subscribe">Subscribe</a></li>
</ul></div> </div>
</div>
<div class="col-md-3">
<div class="footer-widgets">
<h4 class="mvp-widget-footer-title"><span class="mvp-widget-footer-title">About</span></h4>
<div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-153332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153332"><a target="_blank" rel="noopener" href="http://www.babcox.com/brand/underhood-service/">Advertise</a></li>
<li id="menu-item-153396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153396"><a href="https://www.underhoodservice.com/contact/">Contact Us</a></li>
<li id="menu-item-153333" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153333"><a target="_blank" rel="noopener" href="http://babcox.com/about-us/">About Babcox Media</a></li>
<li id="menu-item-157202" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157202"><a href="http://www.babcox.com/contributor-portal/shop-owner-portal/">Content Submission</a></li>
</ul></div> </div>
</div>
<div class="col-md-3">
<div class="footer-widgets">

<section id="text-34" class="mvp-footer-widget widget_text"><div class="mvp-widget-footer"><h4 class="mvp-widget-footer-title"><span class="mvp-widget-footer-title">Location</span></h4></div> <div class="textwidget"><ul>
<li>Babcox Media</li>
<li>3550 Embassy Parkway</li>
<li>Akron, OH 44333-8318</li>
<li>p: (330) 670-1234</li>
<li>f: (330) 670-0874</li>
</ul>
</div>
</section> 
</div>
</div>
<div class="col-md-3">
<div class="footer-widgets footer-widgets-right">
<p style="text-align: center;">
<img src="https://s19539.pcdn.co/wp-content/themes/jawn-child/assets/img/Babcox-Footer-Logo.png" alt="Babcox"><span style="margin-top: 20px;">
<a style="color:#000000;" href="/cdn-cgi/l/email-protection#5b32353d341b393a3938342375383436"><span class="__cf_email__" data-cfemail="86efe8e0e9c6e4e7e4e5e9fea8e5e9eb">[email&#160;protected]</span></a></span>
</p>
</div>
</div>
</div>
<style>
										/* bright edge */
									    .be-ix-link-block .be-related-link-container .be-label,
									    .be-ix-link-block .be-related-link-container .be-list .be-list-item .be-related-link {
										    color: #000000;
										}
										.be-ix-link-block.mvp-foot-marg {
											margin: 0;
											padding: 0;
										}
										</style>
<div class="row mt-3 mt-md-0">

<div class="be-ix-link-block">


</div>
</div>
</div>
</div>
</div>
<div class="mvp-foot-bot left relative">
<div class="mvp-foot-marg">
<div class="mvp-foot-bot-grid">
<div class="mvp-foot-menu relative">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-153412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153412"><a target="_blank" rel="noopener" href="http://babcox.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-157018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157018"><a href="http://www.babcox.com/terms-of-use/">Terms of Use</a></li>
</ul></div> </div>
<div class="mvp-foot-copy relative">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
												var crdate = new Date();
												document.write('<p>Copyright © '+crdate.getFullYear()+' Babcox Media Inc. All Rights Reserved.</p>');
											</script>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
</div>
<div class="mvp-soc-to-top">
<div class="mvp-nav-soc-wrap">
<div class="mvp-nav-soc-title">Connect</div>
<ul class="mvp-nav-soc-list">
<li class="mvp-nav-soc-fb"><a href="https://www.facebook.com/UnderhoodService" target="_blank"><span class="fab fa-facebook-f"></span></a></li>
<li class="mvp-nav-soc-twit"><a href="https://twitter.com/underhoodserv" target="_blank"><span class="fab fa-twitter"></span></a></li>
<li class="mvp-nav-soc-more">
<ul class="mvp-nav-soc-more-list">
<li class="mvp-nav-soc-gram"><a href="https://instagram.com/babcox_underhood" target="_blank"><span class="fab fa-instagram"></span></a></li>
<li class="mvp-nav-soc-yt"><a href="https://www.youtube.com/channel/UCA7Yzkz8Q55bfKSk9SnYPTw" target="_blank"><span class="fab fa-youtube"></span></a></li>
<li class="mvp-nav-soc-link"><a href="https://www.linkedin.com/showcase/underhood-service" target="_blank"><span class="fab fa-linkedin"></span></a></li>
</ul>
</li>
<li class="mvp-nav-soc-but"><span class="mvp-soc-but-grip fas fa-grip-horizontal"></span></li>
</ul>
</div>
<div class="mvp-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
</div>
<div class="mvp-fly-fade mvp-fly-but-click">
</div>
<script type="text/javascript">
	/*
	* Fix the issue caused by the Consend Manager to the Sneaker ad
	* Add the display class when the ad is loaded
	*/
	(function($){
		var interval = null;
		var sneakerAdLoaded = false;
		var sneakerAdLoadedChecked = 0;
		var displayInterval = 43200;
		var currentTime = new Date().getTime();
		var currentInterval = (currentTime - localStorage['sneaker_start']) / 1000;

		$(window).load(function(){
			interval = setInterval(function(){
				if(sneakerAdLoaded || sneakerAdLoadedChecked == 10) {
					clearInterval(interval);
					return;
				}

				sneakerAdLoadedChecked++;

				var container = $('.bs-slide-in-code-container');
				if(container.length>0 && container.find('iframe').height() > 0 && (currentInterval > displayInterval || !currentInterval)) {
					container.parent().addClass('is-visible');
					sneakerAdLoaded = true;
				}
			}, 1000);
		});
	})(jQuery);
</script>
<script type="text/javascript">
	/*
	* Fix the issue caused by the Consend Manager to the top Scroller ad
	*/
	(function($){
		var interval = null;
		var adLoaded = false;
		var adLoadedChecked = 0;
		$(window).load(function(){
			interval = setInterval(function(){
				if(adLoaded || adLoadedChecked == 10) {
					clearInterval(interval);
					return;
				}

				adLoadedChecked++;

				var topAd = $('body > .broadstreet-dynamic-scrolling:visible');
				var top_ad_height = topAd.height();

				if(!top_ad_height) {
					topAd = $('.bs-scroll-container:visible').parent().parent();
					top_ad_height = topAd.height();
				}

				if(top_ad_height < 160) {
					return;
				}

				if(top_ad_height > 0 && parseInt($('body').css('marginTop')) < top_ad_height && top_ad_height ) {
					window.dispatchEvent(new Event('resize'));
					adLoaded = true;
				}

			}, 1000);
		});
	})(jQuery);
</script>
<script>
		olytics.fire({
		    				behaviorId: "9019J3567790A2I", 
				category: "Diagnostics", 
				tag: "diagnostic tools,FLASH Reprogramming,SAE J2534" 
		    		});
		</script>
<a rel="nofollow" style="display:none" href="https://www.underhoodservice.com/?blackhole=1dddc71879" title="Do NOT follow this link or you will be banned from the site!">UnderhoodService</a>
<div data-theiaStickySidebar-sidebarSelector='".mvp-alp-side, #mvp-side-wrap, .mvp-alp-side2, .mvp-widget-latest-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":120,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<broadstreet-zone zone-id="76782"></broadstreet-zone> <script>
            var pc_categories = "diagnostic";
            var pc_tags = "diagnostic-tools, flash-reprogramming, sae-j2534";
        </script>
<link rel='stylesheet' id='garage-studio-widget-css' href='https://s19539.pcdn.co/wp-content/themes/jawn-child/css/garage-studio-widget.css?ver=fa28bd4b4e56a2a24e087252b51f95e6' type='text/css' media='all' />
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"underhoodservice"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"188842 https:\/\/www.underhoodservice.com\/?p=188842","disqusShortname":"underhoodservice","disqusTitle":"Using J2534 Programming Devices","disqusUrl":"https:\/\/www.underhoodservice.com\/using-j2534-programming-devices%ef%bf%bc\/","postId":"188842"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/jawn-alp//scripts/jquery.sticky-kit.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/jawn-alp//scripts/jquery.waypoints.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/theia-sticky-sidebar-custom/js/ResizeSensor.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/theia-sticky-sidebar-custom/js/theia-sticky-sidebar.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/plugins/theia-sticky-sidebar-custom/js/main.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/mvpcustom.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>
	jQuery(document).ready(function($) {
	$(window).load(function(){
	var leaderHeight = $("#mvp-leader-wrap").outerHeight();
	var topHeight = $("#mvp-main-head-wrap").outerHeight();
	var navHeight = $(".mvp-main-head-grid").outerHeight();
	var headerHeight = topHeight + leaderHeight;
	var previousScroll = 0;
	$(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			if ($(window).scrollTop() > headerHeight){
				$(".mvp-main-head-grid").addClass("mvp-nav-fixed");
				//$("#mvp-main-body-wrap").css("margin-top", navHeight);
				$(".mvp-main-head-mid").addClass("mvp-main-head-shade");
				$(".mvp-nav-logo").addClass("mvp-nav-logo-fixed");
				$(".mvp-nav-soc-wrap").addClass("mvp-nav-soc-fixed");
				$("#mvp-search-wrap").addClass("mvp-search-fixed");
				$(".mvp-fly-top").addClass("mvp-to-top");
			} else {
				$(".mvp-main-head-grid").removeClass("mvp-nav-fixed");
				$("#mvp-main-body-wrap").css("margin-top", "0" );
				$(".mvp-main-head-mid").removeClass("mvp-main-head-shade");
				$(".mvp-nav-logo").removeClass("mvp-nav-logo-fixed");
				$(".mvp-nav-soc-wrap").removeClass("mvp-nav-soc-fixed");
				$("#mvp-search-wrap").removeClass("mvp-search-fixed");
				$(".mvp-fly-top").removeClass("mvp-to-top");
			}
			if ($(window).scrollTop() > headerHeight - 70){
				$(".mvp-main-head-grid").addClass("mvp-fixed");
	    		if(scroll < previousScroll) {
					$(".mvp-main-head-grid").addClass("mvp-fixed");
					//$("#mvp-main-body-wrap").css("margin-top", navHeight);
				} else {
					$(".mvp-main-head-grid").removeClass("mvp-fixed");
					$("#mvp-search-wrap").removeClass("mvp-search-toggle");
				}
			} else {
				$(".mvp-main-head-grid").removeClass("mvp-fixed");
				$("#mvp-main-body-wrap").css("margin-top", "0" );
			}
			previousScroll = scroll;
	});

	//$(".mvp-alp-side-in").niceScroll({cursorcolor:"#ccc",cursorwidth: 5,cursorborder: 0,zindex:999999});

	});
	});
	

	jQuery(document).ready(function($) {
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();

  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	
</script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/scripts.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='jawn-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/retina.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='retina-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/flexslider.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='flexslider-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/alp.js?ver=1.0.5' id='alp-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-includes/js/comment-reply.min.js?ver=fa28bd4b4e56a2a24e087252b51f95e6' id='comment-reply-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/intersection-observer.js' id='intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn/js/lozad.min.js' id='lozad-js'></script>
<script type='text/javascript' id='lozad-js-after'>
	var mvpWidgets = document.querySelectorAll("#mvp-home-widget-wrap img");
	lozad(mvpWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script type='text/javascript' src='https://s19539.pcdn.co/wp-content/themes/jawn-child/js/sidebar-menu.js?ver=1.63' id='jawn-sidebar-menu-js-js'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"b9853aee9a","applicationID":"501409725","transactionName":"NVADNxRUVxUAVUENWwwaNBEPGlESFUZRC1cRGggNAlBBSBFeRQ==","queueTime":0,"applicationTime":1027,"atts":"GRcAQVxORBs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
